Image embedding fails looking along incorrect path

Bug #255254 reported by Robin on 2008-08-06
2
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Unassigned

Bug Description

Moving a drawing and related files (the SVG together with the linked image files) results in the SVG file still displaying properly (with the linked images) HOWEVER those images can no longer be embedded.

The linked images in the SVG have an absolute URL, so the links work as long as the images and SVG are kept in the same folder. But the embedding "script" seems to retain the original and relative URL (old path + filename). This means that the images can no longer be embedded as the path is now incorrect, even though the filename is correct and the SVG still displays the drawing as intended. (Exporting works fine too)

Robin (talvenloppu) wrote :

... BTW this seems to me to be linked to bug #255254 and therefore to bug #168542 and bug #246721.

Pablo Trabajos (pajarico) wrote :

Related to bug #386069.

tags: added: bitmap extensions-plugins
Pablo Trabajos (pajarico) wrote :

Problems related to the embedding script have been fixed in #386069. Could you try a recent prerelease and confirm if this bug is still there?

Changed in inkscape:
status: New → Incomplete

I'm a bit slow here: I've got Inkscape 0.46 whats #386069

2009/10/25 Pablo Trabajos <email address hidden>

> Problems related to the embedding script have been fixed in #386069.
> Could you try a recent prerelease and confirm if this bug is still
> there?
>
> ** Changed in: inkscape
> Status: New => Incomplete
>
> --
> Image embedding fails looking along incorrect path
> https://bugs.launchpad.net/bugs/255254
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Inkscape: A Vector Drawing Tool: Incomplete
>
> Bug description:
> Moving a drawing and related files (the SVG together with the linked image
> files) results in the SVG file still displaying properly (with the linked
> images) HOWEVER those images can no longer be embedded.
>
> The linked images in the SVG have an absolute URL, so the links work as
> long as the images and SVG are kept in the same folder. But the embedding
> "script" seems to retain the original and relative URL (old path +
> filename). This means that the images can no longer be embedded as the path
> is now incorrect, even though the filename is correct and the SVG still
> displays the drawing as intended. (Exporting works fine too)
>

su_v (suv-lp) wrote :

Bug #386069 in Inkscape: “Embed extension fails”:
<https://bugs.launchpad.net/inkscape/+bug/386069>

You can get the latest prerelease version 0.47pre4 from:
<http://sourceforge.net/projects/inkscape/files/inkscape/0.47pre4/>

Pablo Trabajos (pajarico) wrote :

Excuse me for not being clearer. Bug #386069 is a another report that seems to describe your same problem and what's fixed recently.

jazzynico (jazzynico) wrote :

It's broken again in 0.48 due to the absolute path bug (Bug #170225 "relative image paths instead of absolute"), but fixed in the trunk.

Changed in inkscape:
importance: Undecided → Medium
milestone: none → 0.49
status: Incomplete → Fix Committed
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers