LPEs are sorted for English/Latin-based locale only

Bug #253298 reported by Alexandre Prokoudine on 2008-07-30
2
Affects Status Importance Assigned to Milestone
Inkscape
Low
Unassigned

Bug Description

LPEs is now sorted alphabetically in the combobox, but that works only for English locale. E.g. in Russian locale they are mixed up.

Sorry, Johan :)

Changed in inkscape:
assignee: nobody → johanengelen
Johan Engelen (johanengelen) wrote :

I don't know how to sort them otherwise, without a lot of effort.
Note: they have been mixed up always! I just made it a little easier for English users.

Changed in inkscape:
assignee: johanengelen → nobody
importance: Undecided → Low
status: New → Confirmed
su_v (suv-lp) on 2013-03-03
tags: added: livepatheffects ui
su_v (suv-lp) wrote :

The new path-effect selector in current trunk (see bug #927074) sorts them according to the current locale AFAICT, even on Ubuntu (12.10).

(Note: on OS X, stable versions (0.47, 0.48.x) as well as current trunk (r12170) sorts them based on the translated strings, but since I'm aware that there are other places in the GUI where lists are sorted on OS X, but not on Linux, I can't tell for sure about whether this is fixed for live path effects across platforms or not - I don't have the locale files for Inkscape stable installed in my Ubuntu VirtualBox, only for local trunk builds).

@Alexandre - any chance you could test with current trunk and report back?
@JazzyNico, Kris - what about Windows (stable, trunk)?

Changed in inkscape:
status: Confirmed → Incomplete

Fix confirmed. Thanks!

Kris (kris-degussem) wrote :

Fixed indeed.

Changed in inkscape:
status: Incomplete → Fix Committed
milestone: none → 0.49
Bryce Harrington (bryce) on 2015-02-21
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers