Wrong bbox calculated if a group contains invisible objects

Bug #252547 reported by khiraly on 2008-07-28
2
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Unassigned

Bug Description

When selecting a group which contains one (or multiple) invisible object(s)
the bounding box includes this invisible objects too, which is very confusing.

Worst case when two groups overlaps (with the invisible objects included) but
visually they are very far from each other.

I have attached an example svg file. Try to drag the vertical line for example.
It always selects the flash(L48) (upper-)left to it.

khiraly (khiraly123) wrote :

fixed in rev 19580; some groups in your file are still larger than visible, but this is because they also contain non-hidden text objects with spaces.

Changed in inkscape:
status: New → Fix Released
khiraly (khiraly123) wrote :

Bulia: Thank you very much. I will modify my extensions to hide the text objects instead to fill it with spaces.

I will test it with windows automated builds. I hope in today's build contains already your fix.

I will report back.

khiraly (khiraly123) wrote :

I can confirm (http://inkscape.modevia.com/win32/Inkscape19594-0808061640.7z), it is fixed in current svn.

The drawing works like a charm! Thank you very much bulia!

However, I needed to modify my extension to appear in the menu:
from:
<inkscape-extension>

to:
<inkscape-extension xmlns="http://www.inkscape.org/namespace/inkscape/extension">

Should be noted in releas notes 0.47.

Thank you very much.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers