A straight line mode for pen tool

Bug #244574 reported by Murray Cumming on 2008-07-01
2
Affects Status Importance Assigned to Milestone
Inkscape
Wishlist
Unassigned

Bug Description

Drawing a straight line currently requires me to use the Pen tool, click at the start, and then double-click at the end. That double-click sometimes results in two points at the end near each other because it's not always possible to keep the cursor over such a tiny target. Presumably I'm triple clicking in those cases, but it happens. I suggest that a special tool for straight lines would be helpful to many people in many cases. It could be coded as a simple specialization of the current Pen tool.

This is not about whether it's possible to draw a straight line. This is about it being awkward and difficult.
Here are a couple of near-duplicates that were closed as invalid, either too quickly or too rudely.
https://bugs.launchpad.net/inkscape/+bug/165615
https://bugs.launchpad.net/inkscape/+bug/171839

Tags: pen Edit Tag help
bbyak (buliabyak) wrote :

If you're having trouble with clicking, increase click/drag threshold in preferences

Changed in inkscape:
importance: Undecided → Wishlist
status: New → Confirmed

I'm not sure if there is need to modify the current behavior since it's easy to commit a straight line with enter after the click on the end point.
Single straight lines can also be done using the pencil tool.

There are two possible methods, and they're easy to achieve.
In both cases, there is no need to perform a double-click.

Murray Cumming (murrayc) wrote :

Again, "This is not about whether it's possible to draw a straight line. This is about it being awkward and difficult."

Murray Cumming (murrayc) wrote :

Thanks for the tip about the enter key though. That's very useful and I wonder if there's a way to make that more discoverable.

On Tue, Jul 1, 2008 at 1:21 PM, Murray Cumming <email address hidden> wrote:
> Thanks for the tip about the enter key though. That's very useful and I
> wonder if there's a way to make that more discoverable.

Always watch the statusbar. When drawing a path, it says "Enter to
finish the path".

bbyak (buliabyak) wrote :

On Tue, Jul 1, 2008 at 2:00 PM, bulia byak <email address hidden> wrote:
> Always watch the statusbar. When drawing a path, it says "Enter to
> finish the path".

And while we're at it, why not add another mode that draws only
horizontal/vertical straight lines.

Thomas Holder (speleo3) wrote :

> And while we're at it, why not add another mode that draws
> only horizontal/vertical straight lines.

already there: press CTRL to snap at 15° steps, so it's easy to go for horizontal or vertical straight lines. Also the "Align and Distribute" tool is useful to make segments horizontal/vertical subsequently.

prkos (prkos) wrote :

Marking as fix released as Pen tool now has the functions you asked for.

Also don't forget that you can also right-click to draw the last node in a path and finish it, so to draw a 2-node path you would go click, right-click. This way you couldn't end up with unnecessary nodes.

Changed in inkscape:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers