Inkscape: A Vector Drawing Tool

No favicon in wiki

Reported by Jens Rantil on 2008-06-24
2
Affects Status Importance Assigned to Milestone
Inkscape
Low
Ian Caldwell

Bug Description

Main Inkscape website (http://www.inkscape.org) has a favicon on their website but Inkscape wiki (http://wiki.inkscape.org) does not.

Jens Rantil (jens-rantil) wrote :

...whether this is a bug or not is debatable and I am posting it here out of simplicity. I am not involved in the Inkscape community much and mailing list is messy to set up for such a small notification like this.

MenTaLguY (mental) wrote :

It's a perfectly reasonable way to track small issues so that they don't get neglected/forgotten.

Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
Leo Jackson (lajjr) wrote :

Isn't the front page just missing?
<link rel="icon" href="favicon.ico" type="image/ico" />
<link rel="SHORTCUT ICON" href="favicon.ico" />

Maybe the logo with a w in it?? mock up attached.

Best Regards,
Leo

Leo Jackson (lajjr) wrote :

Sorry this is the correct mock.

Best Regards,
Leo

tags: added: website
jazzynico (jazzynico) wrote :

The wiki header already has this link tag:
<link rel="shortcut icon" href="/favicon.ico" />

But the link is a 404.
Could someone add the favicon in the wiki root directory?

jazzynico (jazzynico) on 2010-05-16
tags: removed: wiki
Leo Jackson (lajjr) wrote :

I created an Icon that looks good and can be used I can modify any way needed.
Regards,
Leo Jackson

Changed in inkscape:
assignee: nobody → Leo Albert Jackson Jr (lajjr)
status: Confirmed → In Progress
Leo Jackson (lajjr) wrote :

Can this be added to the root directory please.\
Regards,
Leo Jackson

Changed in inkscape:
status: In Progress → Fix Committed
status: Fix Committed → Triaged
Leo Jackson (lajjr) on 2010-07-11
Changed in inkscape:
status: Triaged → Fix Committed
~suv (suv-lp) wrote :

> Triaged → Fix Committed

@Leo - JFTR (and in case we need to ping those with access to the wiki config files/sources to push the change) - where did you commit the favicon for the wiki? I can't find a related commit log message to an inkscape branch hosted on launchpad or to SVN inkscape_web (which does has the favicon.png for inkscape.org) around the time you changed the bug status, and the current wiki doesn't use a favicon either.

Leo Jackson (lajjr) wrote :

@suv,

I was away for a bit I changed to (in progress ). SVN not sure if I have access to that but on bzr I do I think I still do. I can commit to where ever you need?

Regards,
Leo

Changed in inkscape:
status: Fix Committed → In Progress
Leo Jackson (lajjr) wrote :

Added wrong file back sorry

Leo Jackson (lajjr) on 2011-09-18
Changed in inkscape:
status: In Progress → Triaged
~suv (suv-lp) wrote :
~suv (suv-lp) wrote :

Closing - wiki now uses the same favicon as inkscape.org.

@Ian - now finally confirmed with Firefox 8 & Chromium 18.0.979.0 (Safari and Opera still do not use a favicon - possibly because it is a permanent redirection from <http://wiki.inkscape.org/favicon.ico> to <http://wiki.inkscape.org/wiki/favicon.ico> ?

Note: the HTML source defines <http://wiki.inkscape.org/favicon.ico> by referring to it like this:
  <link rel="shortcut icon" href="/favicon.ico" />

Changed in inkscape:
assignee: Leo Jackson (lajjr) → Ian Caldwell (inchosting)
status: Triaged → In Progress
~suv (suv-lp) wrote :

Correction:
- Closing - wiki now uses the same favicon as inkscape.org.
+ Changing status to 'In Progress' - not all browser seem to find the favicon with the current wiki configuration (permanent redirect of '/' root (?)

~suv (suv-lp) wrote :

Closing as 'Fix Released' - works in Safari as well now (only Opera 11.60 still refuses to use the favicon, tested on two different systems, with browser cache emptied repeatedly).

Changed in inkscape:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments