Inkscape saves imported images from openclipart to /tmp

Bug #239669 reported by Nicola Lunghi on 2008-06-13
42
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Inkscape
Low
Unassigned
inkscape (Debian)
Confirmed
Unknown
inkscape (Ubuntu)
Low
Unassigned

Bug Description

Hello to all!!!

I have created a design and I have imported a clipart from openclipart.
I have done some work and the next day I have reopened it.

But in the place of all the openclipart, there's a "Linked image not found"

I have inspectioned more this and the problem is that inkscape save the imported images
by default in /tmp (i'm on ubuntu linux)
and the path to this images point to /tmp also
and when the system is restarted, on linux /tmp is cleared.

And when I click search, for each click is imported and created an image in /tmp

see for example the attached image, i have clicked on horse cuissard, horse and man, horse (lego)
and then restarted with horse cuissard and on the left is my /tmp folder

I think that import from openclipart should ask where to put all imported clipart
(maybe in ~/.inkscape/clipart/myclipart or better in the same folder as .svg file)
or incorporate the image in the .svg file
(in this manner if I need to send the file to another person he/she don't lost all
the imported clipart.

Thanks for your work!!

Nicola Lunghi

Nicola Lunghi (nicola.lunghi) wrote :
Nicola Lunghi (nicola.lunghi) wrote :

My Inkscape version is 0.4.6 in ubuntu hardy

glepore70 (greg-rhobard) wrote :

Confirmed on same version of Inkscape and Ubuntu. What a bummer bug.

0.4.6 built in Fedora 8 is also affected.

Gregor Rosenauer (grexe) wrote :

same here with Kubuntu 8.04 and Inkscape 0.46, with openclipart package 0.18+dfsg-5ubuntu1
 installed.
What an unpleasant surprise... please fix for Intrepid.
I agree with the reporter, the following choices would seem adequate:

1. add a preferences option for storing external clipart:
   a. inline (included with SVG)
   b. as a reference (stored in the same directory, or by a user-definable local clipart-repository)
   c. ask

(similar to Firefox when downloading files,-)

Changed in inkscape:
status: New → Confirmed
jazzynico (jazzynico) wrote :
tags: added: ocal
removed: openclipart path
Changed in inkscape (Ubuntu):
status: New → Confirmed
Alex Valavanis (valavanisalex) wrote :

Also, Inkscape does not clear out the unused clipart files from /tmp when it exits. I think that it would be good practice to put the *wanted* clipart files somewhere non-volatile, as in comment #5, and to delete all *unwanted* images from /tmp upon exit.

Raphaël Pinson (raphink) wrote :

Still present in Inkscape 0.47 (Ubuntu Karmic). This feature is very useful, but it's made unusable by the fact that it saves to /tmp. It can make people work several days on a pic, saving their work regularly, and getting a totally screwed image after they reboot their system. This needs a quick fix.

ScislaC (scislac) wrote :

This may be fixed in 0.48... I need to play with it to determine, but in general, we are "favoring" (based on preference) embedding vs linking.

Changed in inkscape (Debian):
status: Unknown → Confirmed
su_v (suv-lp) on 2010-07-05
tags: added: openclipart
removed: ocal
Changed in inkscape (Ubuntu):
importance: Undecided → Low
Changed in inkscape:
importance: Undecided → Low
Changed in inkscape (Ubuntu):
status: Confirmed → Triaged
Changed in inkscape:
status: Confirmed → Triaged

I have subscribed to this bug in 2008 in the hope to see a fix for it. Today (when its status changed again) it got bored and tried to reproduce the steps, but to my surprise it didn't occurred. So, as far as I have analysed the behaviour of the current version (0.47.6.fc13), the importer of OpenClipart Library now embeds the svgs coming from the internet instead of linking them to the /tmp folder. For me, the bug seems to be resolved. Did I miss something?

Kuntal Majumder (hellozee) wrote :

Cannot reproduce with trunk.

Changed in inkscape:
status: Triaged → Fix Released
Mattia Rizzolo (mapreri) wrote :

as such, I'm marking it as fixed also in ubuntu.

Changed in inkscape (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.