linked offset ungroup issue

Bug #239430 reported by Robert Loos on 2008-06-12
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Adonis Papaderos

Bug Description

when there is an object and its linked object in a group, ungrouping will displace the linked object if the group has a transform-attribute.
Example: draw a square and create a linked offset. select both and put them in a group. move the group. ungroup it, the linked offset will jump away.

Related branches

jazzynico (jazzynico) wrote :

Can't reproduce it on Ubuntu 9.04, Inkscape 0.46-5ubuntu4 and rev. 21514.
Could you please confirm you still have this bug with a recent build?

su_v (suv-lp) wrote :

reproduced with Inkscape 0.46+devel r21461 on OS X 10.5.7

steps to reproduce:
1) create a rectangle
2) create linked offset
3) group path and offset
4) move group
5) ungroup

result: linked offset 'jumps away'

6) group path and 'jumped away' offset
7) move group
8) ungroup

result: linked offset again 'jumps away' - etc.

Robert,

Thank you for reporting this bug and helping Inkscape. I have tried a Windows version, Ubuntu 9.04, Mac OS version I compiled it from 21515. And I went to some early versions as well. I found it in Inkscape 0.46+devel, built Feb 2 2009
It all seemed to do it.

I tried a few things out if you change the recs to paths it doesn't happen. If turn off snaps it doesn't happen.
I think it snaps to closest grids by default if you move the one it moves the other back to original grid.

So by default it is set to happen if you move it a bit it goes back.

just kill the snaps you can change the adjustments or change to paths.

Regards,
Leo

jazzynico (jazzynico) wrote :

Confirmed on Windows XP, Inkscape rev. 21460 and 0.46, when snapping is enabled.

Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
tags: added: snapping

Leo,

If I look at the XML-editor the problem seems to be the following:
When I move the group, it gets a transform-attribute. When I ungroup,
the transform is copied to the linked offset. But also the
inkscape:original attribute is changed which seems to be the fault. If I
simply copy the "d"-attribute to the inkscape:original the linked offset
jumps back where I would expect it. So for this cause it would be
sufficient not to modify the inkscape:original value. I can't say if
this has side effects on other operations.

Cheers

Robert

ScislaC (scislac) wrote :

this is a regression

Changed in inkscape:
importance: Low → High
milestone: none → 0.47
jazzynico (jazzynico) wrote :

ScislaC, I've reproduced it with 0.46, therefore I think it's not a regression.

I have reproduced I didn't get a version that didn't do it yet I will try some others. Robert nice work around, but changing that produces a bad effect in a trial I did it jumped the nodes around not a desired effect for me.

Regards,

Leo

ScislaC (scislac) wrote :

JazzyNico,
I can't recall if we've even had an official release in a while that didn't exhibit the issue, but it's one of those bugs that seems to get fixed and then resurfaces again.

Changed in inkscape:
assignee: nobody → Diederik van Lierop (mail-diedenrezi)

This should have been fixed as of rev. #21634. If not then reopen this bug and leave a comment.

Thanks for reporting!

Changed in inkscape:
status: Confirmed → Fix Released
Syllie (eurosyl1) wrote :

I just re-opened this bug as I am working with Inkscape 0.47pre4 and the exact behaviour as described by ~suv in post 2 is back, so the fix has gone haywire somewhere.

Changed in inkscape:
status: Fix Released → New
Syllie (eurosyl1) wrote :

And of course I should add that I work on WinXP SP3

su_v (suv-lp) wrote :

confirmed with Inkscape 0.47pre4 and 0.46+devel r22575 on OS X 10.5.8
(tested with new preferences.xml, new default document, no visible grid, snapping default unchanged)

not reproduced with paths and rectangle shapes
   paths and <svg:rect> don't store the transformation as a
   preserved 'translate()' property of the 'transform' attribute.
   When ungrouping the new location is re-calculated as optimized
   transformation for both the original and the linked offset.

reproduced with the other shapes (ellipse, star and spiral)
   as described in comment #2.
   When ungrouping the transform attribute of the moved group is added
   to the attributes of the shape but the location for the linked offset is
   not re-calculated nor is the preserved transform attribute added.

Changed in inkscape:
status: New → Confirmed
tags: added: transformations
ScislaC (scislac) on 2009-11-24
Changed in inkscape:
milestone: 0.47 → none

Unassigning myself because I won't be able to work on this anytime soon

Changed in inkscape:
assignee: Diederik van Lierop (mail-diedenrezi) → nobody
su_v (suv-lp) wrote :

Lowering Importance to 'Medium': no crash involved and a workaround exists: convert the shapes to paths before moving, offsetting or grouping/ungrouping them.

Changed in inkscape:
importance: High → Medium
jazzynico (jazzynico) on 2009-12-26
tags: added: groups
jazzynico (jazzynico) on 2010-05-16
tags: removed: ungroup
jazzynico (jazzynico) on 2011-03-17
Changed in inkscape:
assignee: nobody → Adonis Papaderos (ado-papas)
milestone: none → 0.49
status: Confirmed → In Progress
jazzynico (jazzynico) wrote :

Fixed in the trunk, revision 10109.
Thanks Adonis!

Changed in inkscape:
status: In Progress → Fix Committed
tags: added: backport-proposed
Alex Valavanis (valavanisalex) wrote :

Backporting note: The patch doesn't apply cleanly to lp:inkscape/0.48.x r9858 because a 2geom update was introduced in trunk before this bug was fixed.

See also bug #184341 <Linked offsets ignore clone movement preferences>

Krzysztof Kosinski (tweenk) wrote :

Backported to trunk in 9861

Changed in inkscape:
milestone: 0.49 → 0.48.3
tags: removed: backport-proposed
Ted Gould (ted) on 2012-02-15
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers