Inkscape: A Vector Drawing Tool

Display mode toggle needs update to all 3 modes

Reported by Andy Fitzsimon on 2008-06-10
2
Affects Status Importance Assigned to Milestone
Inkscape
Medium
theAdib

Bug Description

Display mode toggle needs to include No-Filters, Normal and outline as part of a toggle cycle.
The new No-Filters display mode exists and now we need to switch between 3 display modes.

Currently only outline and the last selected coloured mode switch on display mode toggle
so (no filters) will switch with (outline) and back or
or (normal) will switch with (outline) and back

Allowing the cycle of all display modes will help as new display modes are created.

imagine switching between (outline), (no bitmaps) (outline with bitmaps) or (no patterns or gradients) as different parts of an illustration are being built..

It would be hard to keep hitting the view menu for a commonly toggled display preference.

Tags: ui Edit Tag help
Changed in inkscape:
assignee: nobody → mental
importance: Undecided → Medium
milestone: none → 0.47
status: New → Confirmed
RIco (rico-rootscore) wrote :

this bug has been reported 8 months ago, and i think it becomes more important to fix it now with all the filters that have been added, as toggling modes becomes vital to avoid Inkscape slowing down too much during design and still having a fast glimpse on the actual render.

Elv13 (elv1313) wrote :

I was about to report it when I saw this one. I also think it is important to fix it before 0.47 final built (just use a char instead of a bool and some define, it should not be that long to fix.

theAdib (theadib) wrote :

attached patch cycles through all 3 display modes normal->without filters->outline
pls test.

HTH, Adib.

Changed in inkscape:
status: Confirmed → In Progress
assignee: MenTaLguY (mental) → theAdib (theadib)
jazzynico (jazzynico) wrote :

Tested on Ubuntu 9.04. Works well.
Thanks Adib!

~suv (suv-lp) wrote :

Tested on OS X 10.5.8. Works well.
Thanks Adib! ;-)

~suv (suv-lp) wrote :

*bump* - more tests needed?

ScislaC (scislac) wrote :

Thanks Adib! Committed in r22269.

Changed in inkscape:
status: In Progress → Fix Released
tags: added: ui

Just one thing: wireframe mode puts a notification to window's caption. "No filter" mode doesn't.

theAdib (theadib) wrote :

Alexandre, there is no hint when you switch the mode manually. So this is not related to this report. pls create a new issue then. Adib.

jimmac (jimmac) wrote :

The keyboard toggle now has 4 modes in 0.48. I wasn't sure about the 3 state toggle, but 4 modes is definitely too much. I strongly believe a toggle should have two states. After extensive use, I can tell toggling multiple states results in wild cycling of the options especially when in many circumstances the modes don't seem to have visible effect on canvas. And I often go one stop too far when toggling, resulting in more frustration.

Having a two state toggle reflects my need to periodically go into outline mode when working on complex and CPU intensive artwork and selecting objects easier (no fill/stroke etc). The standard solution to the UI problem has been to shove another cusomizability into file>inkscape preferences which is already way too full.

I would like to hear feed back from print people as to how they are using the print preview, but I am guessing they depend on the preview to be active most of the time rather than toggling back and forward between normal and print preview. Similarly the no-filters view sounds like something you toggle because the performance with filters is too poor. Again, not something you toggle back and forward all the time. So judging from my own use pattern the outline mode is always the state to toggle to.

The other state would be one of the 3 remaining display modes and would be persistant. So if the view is 'no filters' toggling ctrl+kp5 will go to outline and back to no filters. If the display mode is set to 'print colors preview' toggling goes between that and outline.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers