build failure with gtk+-2.13.x: /usr/include/gtk-2.0/gtk/gtkctree.h:110: error: ‘GtkCList’ does not name a type

Bug #238223 reported by Ed Catmur on 2008-06-07
4
Affects Status Importance Assigned to Milestone
Inkscape
High
Unassigned
Nominated for 0.46.x by Luca Bruno
inkscape (Debian)
Fix Released
Unknown
inkscape (Gentoo Linux)
Fix Released
Undecided
Unassigned
inkscape (Ubuntu)
Undecided
Martin Pitt

Bug Description

 i686-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I.. -I/usr/lib/perl5/5.8.8/i686-linux/CORE -I/usr/include/freetype2 -pthread -DORBIT2=1 -I/usr/include/gnome-vfs-2.0 -I/usr/lib/gnome-vfs-2.0/include -I/usr/include/gconf/2 -I/usr/include/orbit-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/poppler -I/usr/include/poppler/glib -I/usr/include/poppler -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/cairo -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pango-1.0 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/pixman-1 -DPOTRACE=\"potrace\" -pthread -I/usr/include/gdkmm-2.4 -I/usr/lib/gdkmm-2.4/include -I/usr/include/glibmm-2.4 -I/usr/lib/glibmm-2.4/include -I/usr/include/pangomm-1.4 -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/cairomm-1.0 -I/usr/include/sigc++-2.0 -I/usr/lib/sigc++-2.0/include -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pango-1.0 -I/usr/include/cairo -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/pixman-1 -I/usr/include/gtkmm-2.4 -I/usr/lib/gtkmm-2.4/include -I/usr/include/atkmm-1.6 -I/usr/include/atk-1.0 -I/usr/include/libxml2 -I/usr/include/gtkspell-2.0 -I../cxxtest -Wall -Wformat-security -W -Wpointer-arith -Wcast-align -Wsign-compare -Woverloaded-virtual -Wswitch -D_FORTIFY_SOURCE=2 -Wno-unused-parameter -ggdb -O1 -O2 -O3 -pipe -march=athlon-xp -mmmx -msse -m3dnow -MT widgets/sp-xmlview-attr-list.o -MD -MP -MF $depbase.Tpo -c -o widgets/sp-xmlview-attr-list.o widgets/sp-xmlview-attr-list.cpp &&\
 mv -f $depbase.Tpo $depbase.Po
In file included from /usr/include/gtk-2.0/gtk/gtk.h:221,
                 from /usr/include/gtk-2.0/gtk/gtkclist.h:33,
                 from widgets/sp-xmlview-attr-list.h:16,
                 from widgets/sp-xmlview-attr-list.cpp:21:
/usr/include/gtk-2.0/gtk/gtkctree.h:110: error: ‘GtkCList’ does not name a type
/usr/include/gtk-2.0/gtk/gtkctree.h:127: error: ‘GtkCListClass’ does not name a type
/usr/include/gtk-2.0/gtk/gtkctree.h:149: error: ‘GtkCListRow’ does not name a type
/usr/include/gtk-2.0/gtk/gtkctree.h:342: error: ‘GtkCellType’ does not name a type
widgets/sp-xmlview-attr-list.cpp: In function ‘GtkType sp_xmlview_attr_list_get_type()’:
widgets/sp-xmlview-attr-list.cpp:93: warning: deprecated conversion from string constant to ‘gchar*’
make[2]: *** [widgets/sp-xmlview-attr-list.o] Error 1
make[2]: Leaving directory `/var/tmp/portage/media-gfx/inkscape-0.46-r3/work/inkscape-0.46/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/media-gfx/inkscape-0.46-r3/work/inkscape-0.46'
make: *** [all] Error 2

Related branches

Ed Catmur (ed-catmur) wrote :
Bryce Harrington (bryce) wrote :

Confirmed; I saw this error on Ubuntu Intrepid.

Changed in inkscape:
importance: Undecided → High
status: New → Triaged
Cesare Tirabassi (norsetto) wrote :

Looks like this is a bug which should be properly addressed in libgtk2.0 though, please see bug 247909.

Maciej Piechotka (uzytkownik2) wrote :

Also met in Gentoo.

Martin Pitt (pitti) wrote :

Since this is really a bug in GTK, I'm closing the upstream task.

Changed in inkscape:
status: Triaged → Invalid
Martin Pitt (pitti) wrote :

Will upload in a bit.

Changed in inkscape:
assignee: nobody → pitti
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package inkscape - 0.46-2ubuntu1

---------------
inkscape (0.46-2ubuntu1) intrepid; urgency=low

  * Merge with Debian unstable to fix FTBFS with current poppler. See
    0.46-1ubuntu1 for remaining Ubuntu changes.
  * Add 03-gtk-includes.dpatch as a workaround of GTK includes bug
    (LP #247909) to fix FTBFS. (LP: #238223)
  * Build against boost 1.35.

inkscape (0.46-2) unstable; urgency=low

  * chmod a+x inkscape/extensions/xaml2svg/ during install in debian/rules
  * change my email address in debian/control
  * upload sponsored by Guido Guenther <email address hidden>
  * add patch from gentoo to make inkscape build with libpoppler 0.8.3
    http://sources.gentoo.org/viewcvs.py/gentoo-x86/media-gfx/inkscape/files/inkscape-0.46-poppler-0.8.3.patch?view=markup
    (closes: #488170, #489083)

 -- Martin Pitt <email address hidden> Mon, 11 Aug 2008 12:34:34 +0200

Changed in inkscape:
status: Fix Committed → Fix Released
Mart Raudsepp (leio) on 2008-09-28
Changed in inkscape:
status: New → Fix Released
Luca Bruno (lucab) wrote :

Already fixed by ishmal in trunk SVN (r19808). The thing won't probably change in gtk in the next future, so we need to change our code here. It should be safely backported to the 0.46.1 branch...

Changed in inkscape:
milestone: none → 0.46.1
status: Invalid → Fix Committed
jazzynico (jazzynico) on 2009-08-07
Changed in inkscape:
milestone: 0.46.1 → 0.47
tags: added: build
ScislaC (scislac) on 2009-10-05
Changed in inkscape:
status: Fix Committed → Fix Released
Changed in inkscape (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.