Layer text not printed

Bug #231477 reported by jeawrong on 2008-05-17
2
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Unassigned

Bug Description

I have a project in inkscape, formed to 2 layers, graphics (collage of photos) and text (the title of collage). When i print the project, only the graphics layer is printed.
Then I have exported the entire project in a png file, and try to print the file, but the result is the same.
If I open the png file with gimp and print it, the result is ok.

Pablo Trabajos (pajarico) wrote :

We need the SVG file you're trying to print. Please attach it.

tags: added: printing
Changed in inkscape:
status: New → Incomplete
jeawrong (jeawithlove) wrote :

I have made this simple project for test, a graphic layer and a layer text.
If the layer text is on top layers, the text will be printed, but if it is on bottom layers, will not printed.
This have a logic, but the problem is what I see on the screen: if the layer text is on bottom and the layer graphics is on top, why i see the text layer? The graphic layer have some type of transparency?

Pablo Trabajos (pajarico) wrote :

I can't confirm it on 0.47-pre1. The graphic layer with the red object has full opacity and it doesn't let me see the text when it's on top. What version are you using?

jeawrong (jeawithlove) wrote :

0.46 on Kubuntu Jaunty 9.04, KDE 4.2.2

jeawrong (jeawithlove) wrote :

Strange this. I have reopen the simple project with graphic red and text, and now on screen it works good, if layer text is lower graphic this not will show...

su_v (suv-lp) wrote :

This is a glitch with 'Flowed text' it seems. If I select the text object and convert it to text (menu 'Text > Convert to Text'), the stacking order of objects and layers is reflected on screen as expected (tested with Inkscpae r22115).

Or I can trigger to repaint the stack order of the objects on the screen by
1) change layer order (move 'text' to top)
2) select rectangle
3) move it aside to reveal the text
4) move it back to original position
5) text stays above rectangle

su_v (suv-lp) wrote :

retracting my comment above - I misunderstand the issue at hand ;-)

jeawrong: so it seems that the simple test you attached doesn't show
any bug? Does any other of your files reproduce the bug?

jeawrong (jeawithlove) wrote :

Probably not, but is not a bug the problem visual when create a new project?
Simply follow this steps:
1) create a square filled with a color
2) add a layer
3) in this new layer, create a a black text
4) put the layer text in bottom of layers

at this point, the layer text is visible on the square, and not is normal this.
Closed the project, and reopen:
the layer text is now on bottom and not visible.
Put it on top layers, and this result invisible, only a double click on the eye (hide/show layer) show the text on top. Is this normal?

jeawrong:
Check if one of the objects has a filter applied, or some blending mode (check de xml editor).
There's a bug that makes the layer blending mode to be applied to objects created after blending mode change.
I had several problems with that, and took me a while to discover the origin of the visualization errors.

jeawrong (jeawithlove) wrote :

No filter applied on the two layers, I have check the .svg file with an editor text

Changed in inkscape:
status: Incomplete → New
jazzynico (jazzynico) wrote :

Apparently, the issue is not about printing but on canvas rendering.

Not reproduced on Windows XP, Inkscape 0.46 and trunk revision 10948. All layers and objects are correctly rendered depending on their position.

Could you please try to reproduce the issue with a recent Inkscape version and confirm you're still affected?

tags: added: renderer
removed: printing
Changed in inkscape:
importance: Undecided → Medium
status: New → Incomplete
su_v (suv-lp) wrote :

Reproduced with Inkscape 0.47 and 0.48.x with the file attached in comment #2,
not reproduced with Inkscape 0.48+devel r11503 on OS X 10.7.4

The only "trigger" I was able to detect is the zoom level, likely combined with the relation of the size of the rectangle - which is covering the flowed text object - to the visible canvas area at different zoom levels.

Closing as 'Fix Committed' (milestoned for 0.49) - please reopen if you are able to reproduce it with current trunk (and figure out what exactly triggers this rendering error).

Changed in inkscape:
milestone: none → 0.49
status: Incomplete → Fix Committed
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers