Moving a partly erased object extracts and shifts eraser stroke

Bug #224101 reported by Alexandre Prokoudine on 2008-04-29
Affects Status Importance Assigned to Milestone
Jon A. Cruz

Bug Description

1. Draw a rectangle
2. Erase an area inside it
3. Switch to Selector
4. Start moving the object
5. Eraser stroke extracts from it and moves to the right

Same thing happens when you copy/paste such an object. This case is illustrated in the attached file.

Changed in inkscape:
assignee: nobody → jon-joncruz
Marcin Floryan (mfloryan) wrote :

Yes. I can see the same behaviour. Setting to confirmed.

Changed in inkscape:
status: New → Confirmed
Quasar Jarosz (quasar-ja) wrote :

I cannot reproduce this bug under Windows (SVN 18485). Eraser functions exactly as i would expect it to on a rectangle, and the rectangle can be moved with no issues.

sas (sas-sas) wrote :

I can't reproduce this either (Windows XP + SVN revision 18483). Does it depend on some preference setting?

The only thing I could imagine is if it is possible to move the object in
between the time the erasing gesture is completed and the time the erasure
is actually applied to the path via a boolean operation. In that case I
suppose you could have something like erasure -> move -> erasure in wrong
place, but even then it would only be during a very narrow window of time
before the erasure was "committed".

Rygle (rygle) wrote :

Can't reproduce on Win32 SVN 14846.

Is this platform specific? Alexandre and Marcin, what platform are you guys using? Is there something that's been missed in build files for Linux? Similar to the in the /share/extensions directory that is used by Linux, but not by Win32 build.

Jon A. Cruz (jon-joncruz) wrote :

It appears to be from the current state of calligraphy tool, or leftover settings.

Sounds like it's something to take care of overall with all settings.

~suv (suv-lp) on 2009-11-21
tags: added: eraser
jazzynico (jazzynico) wrote :

Not reproduced on Windows XP (0.47) and Ubuntu 9.10 (0.47pre4).
Could you please confirm that you still have this bug (or not)?

~suv (suv-lp) wrote :

not reproduced with Inkscape 0.47-1 and r8888 on OS X 10.5.8,
tested both with existing and default preferences.

jazzynico (jazzynico) wrote :

Alexandre, could you please confirm that this bug is fixed for you now?

Changed in inkscape:
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers