grid in 0.46

Bug #221040 reported by ro-ee on 2008-04-23
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
Johan Engelen

Bug Description

I have a grid with 1.0 spacing in x and y direction, with 2.5 x and y offset in my old 0.45-files. When opening them in 0.46, the grid becomes 1.0 spacing in y, 2.5 spacing in x direction, and 0 offset in x and 2.5 offset in y.

        0.45 0.46
x 1 2.5
y 1 1
ox 2.5 0
oy 2.5 2.5
also, the grid colors are not the same anymore (alpha transparency is much more opaque)

Also, when changing the x offset by entering a number, this does not provoke any change, only pressing the dials left to the input box changes the grid on the image.

nightrow (jb-benoit) wrote :

You have to know that the code handling the grid was completely rewritten for 0.46, in order to have a much better/flexible systeme.
However, the grid settings for 0.45 documents can not be easily transfered in this new system.

I don't know if anything can be improved about the grid parameters transfert from a 0.45 document to a 0.46.

ro-ee (alexander-roalter) wrote :

Nonetheless, the old .45-grids were stored in this form

     gridoriginx="2.5000000px"
     gridoriginy="2.5000000px"

and are translated wrongly to

       originx="0px"
       originy="2.5000000px"
       spacingx="2.5000000px"
       spacingy="1px"

while

       originx="2.5000000px"
       originy="2.5000000px"
       spacingx="1px"
       spacingy="1px"

would be correct.

So there might be a simple solution to it. Or is there a reason, gridoriginx is not directly mapped to originx and grixoriginy to originy, spacingx is set to 1 if nothing else specified, and so is spacingy.

nightrow (jb-benoit) wrote :

Seems like no one answered, i think if you can join the .svg with which you had problem, this could help us identify/solve it.
Thanks in advance.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

nightrow wrote:
> Seems like no one answered, i think if you can join the .svg with which you had problem, this could help us identify/solve it.
> Thanks in advance.
>
The attached SVG file (Palù_del_Fersina.svg) was created with inkscape
0.45, and has a grid with origin at (2.5,2.5) and a spacing of 1 (which
isn't mentioned anywhere in the file, so I assume it defaults back to 1)

When I open the file in inkscape 0.46 and save it again, I get the file
Palù_del_Fersina46.svg, where I get a grid with the
"GridFromPre046Settings" id and x-origin at 0 (wrong), and spacing x at
2.5 (also wrong), while spacingy and originy are ok. Also, the opacities
are not the same as they were defaulted in the 0.45 version.

- --
Cheers,
Alex
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.9 (GNU/Linux)
Comment: Using GnuPG with SUSE - http://enigmail.mozdev.org

iEYEARECAAYFAkkDB28ACgkQ1J0MF2u394xDewCg5M/l0O3URJWNk+Jux1ffeDXX
waEAoOeH9XpC3GfsSDy178J+vwq/VnAV
=TSlr
-----END PGP SIGNATURE-----

Pablo Trabajos (pajarico) wrote :

Confirmed on 0.47-pre1. I'm assigning a low priority because this doesn't cause data-loss and it's easy to solve manually. The developers will have to pronounce themselves if this will be fixed or not. Inkscape detects correctly that the settings of the first file come from an earlier version and assigns id="GridFromPre046Settings" to the grid. The XML editor already shows the conversion at this stage.

I don't know if the mechanism behind this could be tweaked to take correct values instead of the faulty ones that the second file shows.

Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
jazzynico (jazzynico) on 2010-09-26
tags: added: grids
Johan Engelen (johanengelen) wrote :

sorry for the dumb copy-edit typo... fixed finally.
trunk: r10552
0.48.x: r9824

Changed in inkscape:
assignee: nobody → Johan Engelen (johanengelen)
milestone: none → 0.48.3
status: Confirmed → Fix Committed
Ted Gould (ted) on 2012-02-15
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers