Group element in <defs> section lost during copy/paste between inkscape windows

Bug #220521 reported by Daniel Vianna on 2008-04-22
46
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Unassigned

Bug Description

Original Title: fonts lost during copy/paste between inkscape windows

I have an svg file created by Gnumeric which is opened correctly in Inkscape. The problem is, when I copy it and paste it in a new inkscape window, the drawing is pasted correctly but the text goes missing.

Sample file attached.

Ryan Lerch (ryanlerch) wrote :

What Version of inkscape and operating system are you using?

Does this bug occur when copy/pasting between two seperate instances of inkscape (ie, both launched from a shortcut)
or
with child instances (the new 2nd inkscape window opened via inkscape's "new" or "open" functions)?

Changed in inkscape:
importance: Undecided → Low
status: New → Incomplete
Daniel Vianna (dmvianna) wrote :

I'm using Inkscape-0.46-r2 in a Gentoo Linux system, and I tried it with child instances, as I know launching separate instances precludes copy/paste.

ScislaC (scislac) wrote :

Daniel,

By any chance would you be willing to try current SVN of Inkscape to see if the bug has been fixed for you? There has been some work on our clipboard since 0.46 was released.

Daniel Vianna (dmvianna) wrote :

Just checked out SVN. No change. The fonts still get lost when pasting to a "new" inkscape window.

ScislaC (scislac) wrote :

Okay, I've figured out the problem. The document is not carrying over an item in the <defs> section. And for the record, the text isn't actually text either. :) I'm going to look further into this.

Changed in inkscape:
importance: Low → Medium
status: Incomplete → Confirmed
description: updated
Douglas Augusto (daaugusto) wrote :

I'm experiencing the same problem. I'm using "Inkscape 0.46 built Apr 26 2009" (from Debian's SID repository).

Attached is a sample SVG file (created/converted by the pdf2svg tool) in which the "textual" elements disappear when the figure is copied from an Inkscape window and pasted in another Inkscape window.

su_v (suv-lp) on 2010-07-22
tags: added: clipboard
su_v (suv-lp) wrote :

Besides the fact that Inkscape does not fully support SVG <symbols>: This is the same issue as with normal clones (created by Inkscape): bug #169120 (clones are pasted as invisible orphans and not unlinked from their original if the original is not part of the clipboard selection).

Both attached sample files use clones (<use> elements) of <symbol> elements which are stored inside a group in the <defs> section and not included when copy&pasting the visible content into a new document. Only if the group containing the <symbols> is moved inside the top-level group that is copied to the clipboard, the glyphs are visibly rendered in the new document after pasting.

Reproduced with Inkscape 0.48+devel r9640 on OS X 10.5.8.

AFAIU this is a duplicate of bug #169120.

mfigrs (figurski) wrote :

I'm using Inkscape 0.48 under Win7 64bit - same issue.

In many instances when copying/pasting objects containing text between two inkscape windows, the text is lost. But not in all cases. It doesn't matter what was used to create the original svg I'm copying from. I created a few text objects directly in inkscape and when I copy/paste them into a new inkscape window, some text is lost, some is not, sometimes all is lost, sometimes (rarely) all is OK.

I also noticed another thing, that seems like clipboard corruption. First I do some copy/paste within the same svg (text objects). Then I copy from another svg file to the one I've been working on, and some of the old text (that I was copying/pasting previously) appears together with the object pasted from another svg. I realize this may sound confusing, so basically: objects copied to clipboard a few steps back appear together with newly copied text objects when pasted. This happens even if I copy/paste a non-text object in between those steps.

mfigrs (figurski) wrote :

An update to my comment above. Just discovered: this *does not* happen if I ungroup the text objects completely (eliminate all grouping levels).

Shriramana Sharma (jamadagni) wrote :

Please check whether this is a dup of bug 167907...

su_v (suv-lp) on 2013-06-27
tags: added: symbols
jazzynico (jazzynico) on 2013-07-01
Changed in inkscape:
status: Confirmed → Triaged
su_v (suv-lp) on 2015-05-09
tags: added: clones
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers