EMF import fails

Bug #217231 reported by fd on 2008-04-14
6
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Unassigned

Bug Description

Inkscape shows a dialog with the text

Laden der gewünschten Datei C:\Dokumente und Einstellungen\fd\Eigene Dateien\TimingDiagram_ADC.emf fehlgeschlagen

Inkscape Version 0.46 on WinXP

fd (f-daners) wrote :
Ulferikson (ulferikson) wrote :

Hi,
The emf importer is not able to import much more than what Inkscape self has exported.. You might want to try with a newer build though as I have recently corrected some mistakes

I'm having a similar problem.
When I try to import an .emf file (see attached), the system acts as though it worked, but there is no image displayed.

I downloaded inkscape fairly recently, so I would think that I have a new version. In Help>About Inkscape, it says that the build is April 1, 2006. Is there a way to download a newer build?

Urban Landreman wrote:
> In Help>About Inkscape, it says that the build is April 1,
> 2006. Is there a way to download a newer build?
You might find that it's just that the top right of the italicised 8 is
cut off because it goes off the edge. That's how mine looks.

Ulferikson (ulferikson) wrote :

> I downloaded inkscape fairly recently,
> so I would think that I have a new version.
> In Help>About Inkscape, it says that the
> build is April 1, 2006.

You have the latest version released: Inkscape 0.46 from April 1, 2008. And Inkscape 0.47 is still far from alpha/beta testing..

> Is there a way to download a newer build?

Yes there are newer builds in form of snapshots built on an (almost) daily basis at:
http://inkscape.modevia.com/win32/

"Since these are at the very shiny sharp bleeding edge of the current development process, there will be many bugs, inconsistencies, and unfinished parts. We do not consider these to be finished products ourselves, so please don't consider them to be that way either. These are here to provide executable versions of the current development process for testing for those people who wish to participate in open source and to be engaged with the development process. And to participate, we mean help us in debugging the beast."

bass (bass-sp) wrote :

Indeed, with new possibilities other (by definition unfinished) possibilities arises.

On Windows XP, emfprinter produces vector emf format files that Inkscape 0.46 can read. Unfortunately it doesn't put everything in the right place, colour and in the original font, but it does extract the cells and contents without problems. The emf file I've tested was 'printed' (to emf) from within MS Excel 2003.

Please see http://www.inkscapeforum.com/viewtopic.php?f=22&t=2828 for more details (and previous information).
emfprinter: http://emfprinter.sourceforge.net/

Bas

Ulferikson (ulferikson) wrote :

> The emf file I've tested was 'printed' (to emf)
> from within MS Excel 2003.

Can you please open a new bug and attach that file?

bass (bass-sp) wrote :

Naturally. See Mindmap below with which I'd like to explain.

Using Payne's ScrambleAssistant xla, I've first scrambled the original, as the contents (address book) weren't that important. Here's the first page (again) printed from MS Excel (2007 this time), by means of the virtual printer emfprinter. (Without shrinking the document emfprinter will only print a part of the page.)

[Xara Xtreme note] Printed from Lotus Symphony, it did print the whole page (fit everything in one page as originally intended for A4 paper), but then only the last cell was there and the other objects (cells) were textless.

For now I'm having trouble reinstalling emfprinter, so I've provided an Excel 2007 emf out file (through emfprinter) from within Vista, with this result: see attachments.

One of the files came from IBM Symphony. Only this file produces the same effect I was talking about in Inkscape, the app we're talking about here;) It appears that the four files from WinVísta does contain text, although while Xtreme does reproduce the yellow bars, in Inkscape there seems to appear nothing at all.

I'll come back when I have emfprinter up and running again on XP, perhaps sooner, to give you the file that you asked about.

Thank you for this opportunity.

Bas

bass (bass-sp) wrote :

I've attached the file you've asked for. (With ScrambleAssistant being used on the original xls.)

I've installed xls 2003 viewer on WinXP where IBM Symphony was installed, and used it to recreate the emf file. The emf file is the upper left part of the first page. (Amazing how much it gets compressed with all this information, perhaps we're used to bloated file sizes;) Of course the fonts are not included, so it's still roughly 19000 bits..)

Ulferikson (ulferikson) wrote :

Besides a slight shift and size issue (similar to but not as extreme as bug #341847) the images look the same in Inkscape 0.46+devel as in Windows XP's image viewer. You are using the old Inkscape 0.46 release, right?

bass (bass-sp) wrote :

Indeed you're right. As I have neglegted to carefully read this topic, even the comment right above the one I started, I've missed the amount of work of what's already have been done (ie. I downloaded Inkscape20887-0903121753.7z from http://inkscape.modevia.com/win32/). Sorry if you were forced to repeat yourself. Great work. It works.

theAdib (theadib) wrote :

bass,
do you confirm the issue has been solved using latest development build?
We need to set the status to either "fix released" if the problem has been solved or "confirmed" if the reported issue is still there.
Thx, Adib.

tags: added: emf importing win32

Hello,

No, the problem persists.

I re-downloaded version .46 for Windows XP Professional

When I open the attached file in Illustrator, I get:

When I import the same file in Inkscape, I get:

I've attached the example .wmf file for your examination.

Please tell me if I need to do something differently.
Thank you.

Urban Landreman

****************************************
"Public Health - heart, passion, then data" - Nancy Krieger, APHA
Conference, November 1997

Urban Landreman
Assessment Unit
Hennepin County Human Services and Public Health Department
Public Health Protection
525 Portland Avenue S
Minneapolis, Minnesota 55415

(612) 348-2283 [voice] (612) 348-3830 [fax]

theAdib <email address hidden>
Sent by: <email address hidden>
04/10/2009 03:21 PM
Please respond to
Bug 217231 <email address hidden>

To
<email address hidden>
cc

Subject
[Bug 217231] Re: EMF import fails

bass,
do you confirm the issue has been solved using latest development build?
We need to set the status to either "fix released" if the problem has been
solved or "confirmed" if the reported issue is still there.
Thx, Adib.

** Tags added: emf importing win32

--
EMF import fails
https://bugs.launchpad.net/bugs/217231
You received this bug notification because you are a direct subscriber
of the bug.

Status in Inkscape: A Vector Drawing Tool: New

Bug description:
Inkscape shows a dialog with the text

Laden der gewünschten Datei C:\Dokumente und Einstellungen\fd\Eigene
Dateien\TimingDiagram_ADC.emf fehlgeschlagen

Inkscape Version 0.46 on WinXP

Disclaimer: Information in this message or an attachment may be government
data and thereby subject to the Minnesota Government Data Practices Act,
Minnesota Statutes, Chapter 13, may be subject to attorney-client or work
product privilege, may be confidential, privileged, proprietary, or
otherwise protected, and the unauthorized review, copying, retransmission,
or other use or disclosure of the information is strictly prohibited. If
you are not the intended recipient of this message, please immediately
notify the sender of the transmission error and then promptly delete this
message from your computer system.

Alvin Penner (apenner) wrote :

attached is the svg imported version of the file Brief6_Figure4. This was done using the latest development version for Windows. The development versions are available at :
http://inkscape.modevia.com/win32/

Alvin Penner (apenner) wrote :

Urban,
    could you confirm that the problem has been solved?

bass (bass-sp) wrote :

Tnx, Adib,

using the path 'EMFprinter with a MS xls source in Lotus Symphony, and drag'ndrop in a running Inkscape20887-0903121753.7z (12-Mar-2009)', the emf file correctly appeared, but without the yellow bars running through, and in the far down right corner. I'm now trying the latest build.

Using the above approach (with Inkscape 12-mar-2009 devel build) with MS Vista and Excel 07, where EMFprinter itself had trouble functioning, the said yellow bars correctly appeared in the correct border.

Windows 'Picture and Fax Viewer' was used as a reference.

Full fix undecided. Trying latest build Inkscape21115-0904101557.7z (10-apr-2009).

Bass

bass (bass-sp) wrote :

Latest Inkscape build (april 10) produced the same results. The BoundingBox was set incorrectly (emf appearing in bottom right corner, and the yellow bars did not show.

Other than that, I couldn't find any other flaw. The emf files from MS Vista and Excel 07 again appeared correctly as with the march 12 build.

Strictly this means the problem is confirmed, but could very much be worked with.

Thank you,
Bass

Hello,

I did confirm that the April 10 release does import the .wmf file.
Thank you very much for whatever you did to fix this bug.
I'll now move to step 2 and test out more of Inkscape's features.

Urban Landreman
****************************************
"Public Health - heart, passion, then data" - Nancy Krieger, APHA
Conference, November 1997

Urban Landreman
Assessment Unit
Hennepin County Human Services and Public Health Department
Public Health Protection
525 Portland Avenue S
Minneapolis, Minnesota 55415

(612) 348-2283 [voice] (612) 348-3830 [fax]

Alvin Penner <email address hidden>
Sent by: <email address hidden>
04/11/2009 05:36 AM
Please respond to
Bug 217231 <email address hidden>

To
<email address hidden>
cc

Subject
[Bug 217231] Re: EMF import fails

Urban,
    could you confirm that the problem has been solved?

--
EMF import fails
https://bugs.launchpad.net/bugs/217231
You received this bug notification because you are a direct subscriber
of the bug.

Status in Inkscape: A Vector Drawing Tool: New

Bug description:
Inkscape shows a dialog with the text

Laden der gewünschten Datei C:\Dokumente und Einstellungen\fd\Eigene
Dateien\TimingDiagram_ADC.emf fehlgeschlagen

Inkscape Version 0.46 on WinXP

Disclaimer: Information in this message or an attachment may be government
data and thereby subject to the Minnesota Government Data Practices Act,
Minnesota Statutes, Chapter 13, may be subject to attorney-client or work
product privilege, may be confidential, privileged, proprietary, or
otherwise protected, and the unauthorized review, copying, retransmission,
or other use or disclosure of the information is strictly prohibited. If
you are not the intended recipient of this message, please immediately
notify the sender of the transmission error and then promptly delete this
message from your computer system.

Alvin Penner (apenner) wrote :

it looks to me as though the original failure has been fixed, so I'm going to mark this as Fix Released.
 if there are still unresolved issues concerning the quality of the rendering, perhaps a new bug report could be opened to deal more specifically with that.

Changed in inkscape:
status: New → Fix Released
Alvin Penner (apenner) wrote :

due to discussion of emf import, noticed that the import of the file TimingDiagram_ADC.emf is broken in trunk. This was working properly in Inkscape 0.48.3.1, not sure when it got broken (possibly in bzr commit 10045).
in any event, re-implemented some very limited filtering of control characters, the file now loads correctly.

committed to rev 11775.

bass (bass-sp) wrote :

Thank you Alvin,

your work and effort inspires me to make my work (whatever the subject)
appreciated as well.

B

Op do·11·okt·2012 0:38:05 (week 41), schreef Alvin Penner <alvin@snip>:

> due to discussion of emf import, noticed that the import of the file
> TimingDiagram_ADC.emf is broken in trunk. This was working properly in
> Inkscape 0.48.3.1, not sure when it got broken (possibly in bzr commit
> 10045).
> in any event, re-implemented some very limited filtering of control
> characters, the file now loads correctly.
>
> committed to rev 11775.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers