Large blurred objects don't export

Bug #214132 reported by markm on 2008-04-08
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Unassigned

Bug Description

A poster I am making has a very large circle that has a 50% blur. I found that I could not go above 25% blur and still have the blurred object render on export. Attached is a sample of a 5000 * 5000px black square over a yellow square. Try blurring the black square by 100% and exporting the yellow square at 300dpi. The resulting export.png will just be the yellow square.

markm (h1m533) wrote :
bbyak (buliabyak) wrote :

confirmed in svn, blur that large requires a pixel buffer of almost 3 gb, allocating it fails

Changed in inkscape:
status: New → Confirmed
markm (h1m533) wrote :

Just to make sure, the image does export. The yellow square from the example is exported, but the blurred black square is gone. I suppose like you say, the allocation fails, but then Inkscape just silently moves on.

jazzynico (jazzynico) on 2010-05-16
tags: added: exporting filters-svg
jazzynico (jazzynico) on 2010-05-16
tags: added: performance
Changed in inkscape:
importance: Undecided → Medium
Beluga (buovjaga) wrote :

I can export so the black square is visible. I have 32GB of memory, so that might explain it. It took several minutes.

Arch Linux 64-bit, KDE Plasma 5
Inkscape 0.92pre1 15054 (GTK3)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments