Making a circle produces a Path, not a Circle element

Bug #210109 reported by Martin Andersen on 2008-04-01
52
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Inkscape
Low
Tavmjong Bah
Nominated for 0.47.x by dabski
Nominated for 0.48.x by dabski
Nominated for Old by dabski

Bug Description

As the summary says: Making a circle produces a Path, not a Circle element
Additionally it puts a bunch of duplicate proprietary Sodipodi properties (type;cx;cy;rx;ry) which wouldn't be necessary if it used Circle. Any reason to keep these legacy properties? Else convert them to "Inkscape".

Petr Dlouhý (petr-dlouhy) wrote :

The reason, why it is path and not circle seems to be, that circle element doesen't support arc and segment. Read http://www.w3.org/TR/SVG11/shapes.html#CircleElement

Changed in inkscape:
status: New → Invalid
Martin Andersen (msandersen) wrote :

It seems to me that for the sake of clean markup, if it's a closed circle or ellipse, as they are by default, Inkscape should use the Circle or Ellipse element, else it use the elliptical arc:
http://www.w3.org/TR/SVG11/paths.html#PathDataEllipticalArcCommands

Petr Dlouhý (petr-dlouhy) wrote :

To make circle/elipse with c/e element would be more semantical (it uses elliptical arc yet), but I am not sure, if somebody wants to give work into this.

Changed in inkscape:
status: Invalid → Confirmed

The main difficulty is that a lot of Inkscape (and, indeed, SVG) features don't work on circles or ellipses, only paths. The best solution would be to use an ellipse or circle when possible, and automatically switch to using a path when some feature that requires a path is used.

Martin Andersen (msandersen) wrote :

That's what I had in mind. What, apart from the arcs, doesn't work on circles or ellipses?
If you perform path operations on two objects, obviously the result is a path. Currently I can use a circle element in a compound operation, like combine, which turns the circle into a path, punching a hole in another shape. I doubt that circle could be made back into a Circle element if broken apart, but what would be neat is if you've made an arc, and you have your Sodipodi attributes, if you close the arc again, it can be made back into a circle or ellipse element.

> What, apart from the arcs, doesn't work on circles or ellipses?

The first thing that comes to mind is text-on-path, which was the reason
we started creating circles/ellipses as paths in the first place (being
able to put text on a circle was a popular request). There's also SVG
markers, and anything having to do with path nodes generally ... it
might actually be easier (and shorter) to list the SVG shape-related
features that *do* work with circles and ellipses, rather than listing
all the ones that don't. The features that *do* work are:

 - stroking and filling
 - use as a clipping path

Can you think of any others?

nightrow (jb-benoit) on 2008-04-23
Changed in inkscape:
importance: Undecided → Low
dabski (benjamin-debski) wrote :

It would be nice to have it use the circle element instead of a path and only convert it when the user changes it via the Object to Path function.

su_v (suv-lp) on 2010-05-10
tags: added: shape-editing svg
heyzuess (heyzeuss) wrote :

I would also like to have svg circle elements because that would help me build a lighter, cleaner web page.

su_v (suv-lp) wrote :

Support for SVG <circle> and <ellipse> added in r12670:
- Revision 12670: Seamlessly switch between SVG circle, ellipse, and path (arc) elements while using the Circle, Ellipse, and Arc tool.
  <http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/12670>

See also:
<http://thread.gmane.org/gmane.comp.graphics.inkscape.devel/41694>

Changed in inkscape:
assignee: nobody → Tavmjong Bah (tavmjong-free)
milestone: none → 0.49
status: Confirmed → Fix Committed
Bryce Harrington (bryce) on 2015-02-21
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers