[PATCH] The desktop file doesn't contain MIME type of compressed SVG

Bug #190420 reported by Lubomir Rintel on 2008-02-09
2
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Krzysztof Kosinski
inkscape (Fedora)
Fix Released
Low

Bug Description

Inkscape is not the default association for .svgz files, and it should be.
Patch from Fedora project that modifies the .desktop file accordingly is attached.

It also fixes some more issues, namely these:

inkscape.desktop.in: warning: key "Encoding" in group "Desktop Entry" is deprecated
inkscape.desktop.in: warning: value "Application;Graphics;VectorGraphics;GTK;" for key "Categories" in group "Desktop Entry" contains a deprecated value "Application"
inkscape.desktop.in: error: value "image/svg+xml" for string list key "MimeType" in group "Desktop Entry" does not have a semicolon (';') as trailing character
inkscape.desktop.in: warning: key "FilePattern" in group "Desktop Entry" is deprecated
inkscape.desktop.in: error: value "inkscape" for regexp list key "FilePattern" in group "Desktop Entry" does not have a semicolon (';') as trailing character

Moreover it removes .svg extension from the icon file.
The icon lookup algorithm [1] basically works like following, so there is no need to include the extension:

      for extension in ("png", "svg", "xpm") {
          filename = directory/$(themename)/subdir/iconname.extension
          if exist filename
     return filename
      }

I'm not if it's strictly invalid, but Fedora build system no longer allows packages to include the extension, so ommiting the extension upstream probably won't break anything and will save us from patching :)

[1] http://standards.freedesktop.org/icon-theme-spec/icon-theme-spec-latest.html#icon_lookup

Inkscape is not registered as a .svgz handler (image/svg+xml-compressed) in GNOME

svgz files are just gzip-compressed svg files, inkscape reads and writes them fine

inkscape-0.45.1-1.fc7.x86_64

Hmm, there seems to be something odd in gnome-mime-data too, where
gnome-vfs.keys and gnome-vfs.mime still list 'svgz' as being part of image/svg+xml.

Adding ';image/svg+xml-compressed' to the desktop file fixes the problem. I'll
put that in CVS.

What CVS was this change made in? In Fedora there haven't been any builds or
updates for Inkscape since May.

I attempted to fix this in inkscape-0.45.1-3.fc9. Does that fix thing for you?

:}
(In reply to comment #3)
> Does that fix thing for you?
Does that fix fix the thing for you?
Does that fix work for you?

Damn, I thought I had already responded to this bug a long time ago

The problem is fixed on my system, but I don't know if it is on Will's

Woo hoo, nothing better to do on Sunday afternoon than close trivial Inkscape
bugs...

inkscape-0.45.1-4.fc8 has been pushed to the Fedora 8 testing repository. If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with
 su -c 'yum --enablerepo=updates-testing update inkscape'

inkscape-0.45.1-4.fc8 has been pushed to the Fedora 8 stable repository. If problems still persist, please make note of it in this bug report.

Lubomir Rintel (lkundrak) wrote :
Changed in inkscape:
status: Unknown → Fix Released
Ryan Lerch (ryanlerch) on 2008-03-30
Changed in inkscape:
status: New → Confirmed
Krzysztof Kosinski (tweenk) wrote :

Fixed in SVN 18204

Changed in inkscape:
assignee: nobody → tweenk
status: Confirmed → Fix Committed
bbyak (buliabyak) wrote :

when closing bugs, please set them to fix released

Changed in inkscape:
status: Fix Committed → Fix Released
Changed in inkscape (Fedora):
importance: Unknown → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.