curve is exported badly (but displayed correctly)

Bug #189214 reported by choff on 2008-02-05
144
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Krzysztof Kosinski

Bug Description

I've had a curved path (imported from illustrator and modified in inkscape) that was displayed all-right on screen, but on the png-export it always appeared cropped. The outer convex line was drawn straight instead of bent. As a workaround I had to add a node in the curve, and then the export worked fine. First time I ever came across this issue, no big deal maybe, but I thought this would give you a hint that something in the export is not always working well. I can provide you with the file, if you wish to reproduce.

Inkscape 0.45+0.46pre0+devel, built Jan 15 2008, on win xp

btw: awesome tool, thanks for your effort!

bbyak (buliabyak) wrote :

you need to attach the svg file demonstrating this

Tom Davidson (tjd-mit) on 2008-02-05
Changed in inkscape:
status: New → Incomplete
choff (saperlipopette) wrote :

sorry, didn't see this option when filing the bug..
The file correct_display.svg displays all the curves fine, both in inkscape and firefox. The corrupt_export.png does not.

Tom Davidson (tjd-mit) wrote :

Hmm... I can export this file just fine. Using Linux (Fedora Core 6) svn rev 17236.

I get correct rendering whether I use the file->export dialog, or the command line. The attached file was generated using the following command:
 $ inkscape -D -e ~/tmp/correct_export_commandline.png ~/tmp/correct_display.svg

Can someone else try this under windows?

I confirm this bug in Inkscape 0.47 under Windows XP. But it depends on the resolution at which the image is exported. If I export at 90dpi (giving a 744 x 1052 PNG) then the image is fine. But if I export at 1240 x 1754, as the bug reporter did, then the problem appears. At 1414 x 2000 there is no problem. (Note that Tom Davidson's export is at 90dpi, and is of the drawing rather than the whole page.)

If I add a new node (double-click) at the top of the problematic curve, then the 1240 x 1754 export is correct.

I think I've seen this sort of behaviour before, so this is probably a duplicate of another bug report.

Changed in inkscape:
status: Incomplete → Confirmed
su_v (suv-lp) wrote :

reproduced bug in page-sized bitmap export (150 dpi) + fix by adding node with Inkscape 0.47 on OS X 10.5.8

tags: added: bitmap exporting renderer
removed: win32
summary: - curve is exported badly (but displayed correctly)w
+ curve is exported badly (but displayed correctly)
jazzynico (jazzynico) on 2010-05-15
Changed in inkscape:
importance: Undecided → Medium

I was able to distil this to a minimal test case, containing just 3 nodes with whole number coordinates. I hope that a developer can use this to manually step through the rendering code and check each step.

Export the attached file at 100 dpi.

I'm unsure what "adding a new node at the top of the problematic curve" means. What kind of node is this about?

@Sebatian:
I think sas means that if you click the segment that exports badly using the node tool, and then press "Insert node into segment", it will export without problems.

You can easily confirm this with my minimal test case.

Krzysztof Kosinski (tweenk) wrote :

Fixed by Cairo renderer.

Changed in inkscape:
assignee: nobody → Krzysztof Kosinski (tweenk)
milestone: none → 0.49
status: Confirmed → Fix Committed
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.