Inkscape: A Vector Drawing Tool

Broken editing of text with absolute kerning

Reported by Joe Ubuntu on 2008-02-04
64
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Unassigned

Bug Description

I am using the Ubuntu/Gutsy 0.46pre0 package and have discovered the following bug when importing PDFs: text boxes in the converted file cannot be edited properly. Even when objects are ungrouped, any attempt to edit the text boxes fails: Any new text entered is placed one letter on top of the other, and previously existing text cannot be selected (see screenshot). If a new textbox is created within the same file, however, the problem does not occur.

Thanks for working on what will be a powerful, free PDF editor!

=====================
UPDATE: Apparently, the text can be edited once the text box is selected and "Remove manual kerns" is selected from the Text menu. But, I think this is still a bug; regular text does not behave this way.

Joe Ubuntu (josephdm) on 2008-02-04
description: updated

See http://wiki.inkscape.org/wiki/index.php/ReleaseNotes046#PDF_and_AI_import

Basically this is a wontfix. We cannot sacrifice precise text placement, without it PDF import will be meaningless because this format is specifically designed for precise layout. Editing such text is naturally not so easy as regular text, but there's a workaround.

Changed in inkscape:
status: New → Won't Fix
~suv (suv-lp) on 2009-10-30
tags: added: importing pdf text
Anton (benderamp) wrote :

My first and all further impressions of imported text when I tried to edit imported text it gave me an impression that something was completely broken inside text field during import - this looked like old bugs with multybite characters in linux terminals (when type some text in russian, then try to delete it, the character is not deleted, but caret moves on its place then everything gets worse and comes to a mess).

The idea to import/export PDF came to me when I was searching a universal file format to exchange data between different vector drawing programs - corel draw, ai, inkscape. As far as PDF were a good candidate to this role, my first tests showed me that inkscape itself can't import pdf files correctly (and only whey my bug was marked as duplicate of this bug I found that this is not so). I am more than sure that other users with same intentions would receive the same impression and would give up using PDF as interchange format.

In may cases presise text letter position is not nessesary because in simple drawings users would just type some text and would not apply any special letter spacing settings to it, but this text can't be obviously edited either.

My suggestion is to place additional check box on the PDF import dialog like "remove manual kerns" and a short description on what it affects, so this feature won't look like a bug anymore.

Krzysztof Kosinski (tweenk) wrote :

This is not a "Won't Fix". It should be possible to edit text with absolute kerning. If it's possible to convert from relative to absolute kerning required for display, then it should also be possible to convert from absolute to relative kerning for editing.

summary: - PDF-imported text boxes cannot be edited properly
+ Broken editing of text with absolute kerning
Changed in inkscape:
status: Won't Fix → Confirmed
importance: Undecided → Medium
MOW (wolter) wrote :

@#2:
Well, obviously entering new text isn't already precisely placed, so newly entered letters should appear normally and not on top of each other. I can live with old text staying in place until absolute kerning is removed, but it makes no sense to put new text on (inherited) absolute positions which would in almost all cases be wrong anyway.

I have a pdf where several labels, scattered wildly around the place, are actually the same text box. When moving in text at one position and the cursor goes to the next area the cursor sometimes jumps just off-screen, and sometimes text jumps to a completely different screen position. The best way to make changes to this seems to be deleting the characters of a label and create a new text box at that place, but that can get annoying with all the cursor jumps. I'd rather overwrite the labels in the existing box. Obviously removing ALL absolute positioning from that text box wouldn't be a good idea, so I'd appreciate if it would be removed just for the new text I'm entering, or for just the segment I'm currently in.

Example pdf: http://www.uni-bremen.de/fileadmin/user_upload/universitaet/lageplan/uniplan_a3.pdf - try editing the building labels.

Until this is fixed, this information should be easier to find.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers