Linked offsets ignore clone movement preferences

Bug #184341 reported by Artis Rozentāls on 2008-01-19
2
Affects Status Importance Assigned to Milestone
Inkscape
Low
Adonis Papaderos

Bug Description

Linked offsets move with the original even when the preferences specify that they shouldn't. This happens both in 0.45 and svn trunk.

Related branches

Ryan Lerch (ryanlerch) wrote :

Confirmed on windows vista business.
However, im not sure of how that setting in the inkscape pref's is worded. from my experience i would want clones to stay unmoved, but linked offsets to move...

Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
Artis Rozentāls (artis) wrote :

In SVN the setting is worded "When the original moves, it's clones and linked offsets:" which clearly indicates that the behaviour should apply to both.

prkos (prkos) wrote :

In build 19587 linked offset of paths seems to switch the behaviour of the first and third option (If you choose Move in parallel it Moves according to transform and vice versa) and the second option Stay Unmoved actually Moves in parallel.

Spiral and Elipse seem to respect the first 2 options as expected, but they don't respect the 3rd one (The linked offset doesn't move when Move according to transform is selected.)

su_v (suv-lp) wrote :

Related to or duplicate of
Bug #167419 “square/circle/polygon/spiral and linked offset misbehaviours”

tags: added: shape-editing transformations
jazzynico (jazzynico) on 2011-03-17
Changed in inkscape:
assignee: nobody → Adonis Papaderos (ado-papas)
milestone: none → 0.49
status: Confirmed → In Progress
jazzynico (jazzynico) wrote :

Fixed in the trunk, revision 10109.
Thanks Adonis!

Changed in inkscape:
status: In Progress → Fix Committed
tags: added: backport-proposed
Alex Valavanis (valavanisalex) wrote :

Backporting note: The patch doesn't apply cleanly to lp:inkscape/0.48.x r9858 because a 2geom update was introduced in trunk before this bug was fixed.

Krzysztof Kosinski (tweenk) wrote :

Backported to trunk in 9861

Changed in inkscape:
milestone: 0.49 → 0.48.3
tags: removed: backport-proposed
Ted Gould (ted) on 2012-02-15
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers