"Color managed view" menu item should be a checkbox

Bug #183956 reported by Alexandre Prokoudine on 2008-01-18
Affects Status Importance Assigned to Milestone
John Smith

Bug Description

When scrollbars are switched off, it's impossible to say if color management is on or off. Thus "Color managed view" menu item should be a checkbox.

Changed in inkscape:
assignee: nobody → jon-joncruz
milestone: none → 0.46
Bryce Harrington (bryce) wrote :

Could you explain the issue in more depth?

Changed in inkscape:
status: New → Incomplete

Sure :)

Usually color management is something that is configured once and forever (the golden don't-touch-if-it-works rule), but if some aspects of it can be changed or the whole color management be switched off via command in a menu, there should be a straight visual report for current status.

Inkscape puts a) an icon to crossing of vertical and horizontal scrollbars to tell if it's on or off and b) a toggle to View menu which has only an icon, but no chekcbox. A lot of users disable scrollbars, thus they are unable to say at once if CM is enabled or disabled unless they remember it precisely. To find out if it's on or off they need to a) enable scrollbar either by Ctrl+B or from menu in top left part of the screen and look at the corner in the bottom right part of the screen b) judge by the colorfulness of the small icon if CM is on or off (and it takes time).

If you look at other applications playing on the desktop publishing arena, they _never_use icons in menu. They use checkboxes. This is because checkbox is the easiest way to inform users on current status of some option. A toggle that bounds you to a) a tiny icon in the other part of the screen that is b) not always present (scrollbars off) is a challenge.

That said, Scribus does put an icon for CM on/off option to its status bar too, but at least it's always present (and I personally don't like that approach either way).

Ryan Lerch (ryanlerch) wrote :

Is this going to get implemented for 0.46?

Changed in inkscape:
importance: Undecided → Wishlist
Bryce Harrington (bryce) wrote :

Thanks, that clarifies the issue. I agree this would be a good feature to add, but sounds like users will still be able to access it if they leave scrollbars on, so I don't think this is absolutely required for the release. If it gets implemented in time we can look at including it, but otherwise I think we can push it to 0.47.

Changed in inkscape:
assignee: jon-joncruz → nobody
milestone: 0.46 → 0.47
Changed in inkscape:
assignee: nobody → jon-joncruz
status: Incomplete → Confirmed
ScislaC (scislac) on 2009-11-24
Changed in inkscape:
milestone: 0.47 → none
jazzynico (jazzynico) on 2010-07-02
tags: added: color ui
~suv (suv-lp) wrote :

Fixed in r11600 (see bug #819671 comment #5)

Known issues with global menubar (Ubuntu Unity) are tracked in bug #1136344.

Changed in inkscape:
assignee: Jon A. Cruz (jon-joncruz) → John Smith (john-smithi)
milestone: none → 0.49
status: Confirmed → Fix Committed
Bryce Harrington (bryce) on 2015-02-21
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers