menu bar file -> save as... show wrong chinese character

Bug #1802726 reported by frank zhang on 2018-11-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Patrick Storz

Bug Description

When I open a new svg file and click menu bar file -> save as ... , there are wrong chinese character
shown on the poped out dialog.

version: 0.92.3
os: win7
lang: zh

Tags: ui Edit Tag help
frank zhang (frankzhang) wrote :
frank zhang (frankzhang) on 2018-11-11
description: updated
Patrick Storz (ede123) wrote :

That's the "title" field and I assume with "wrong" you meant improperly translated?

As translations are user contributed the best thing you can do is fix the translation yourself, see [1] for details.

[1] https://inkscape.org/contribute/translations/

tags: added: translation
removed: chinese
Changed in inkscape:
status: New → Invalid
frank zhang (frankzhang) wrote :

It is not improperly translated. It is meanless word mixed with vierd symbol.

I checked the zh_CN.po file. It is right.

title in chinese is "标题"-two chinese characters.

It caused by wrong encoding type because win7 encoding chinese by gbk, not utf-8. the strang thing is other chinese in inkscape user interface is shown correctly. I guess other chinese use right encoding type.

Patrick Storz (ede123) on 2018-11-11
Changed in inkscape:
status: Invalid → New
tags: added: ui
removed: translation
Patrick Storz (ede123) wrote :

Ah, OK, I see. I think I know what's wrong, should be easy to fix.

Changed in inkscape:
assignee: nobody → Patrick Storz (ede123)
milestone: none → 0.92.4
Patrick Storz (ede123) wrote :
Changed in inkscape:
status: New → Fix Committed
frank zhang (frankzhang) wrote :

where should I download the windows build in gitlab? I only found mac and linux packages.

Alvin Penner (apenner) wrote :
frank zhang (frankzhang) wrote :

I have try this package. It is correct now.

Patrick Storz (ede123) wrote :

Thank you for confirming!

Bryce Harrington (bryce) on 2019-01-18
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers