deleting bottom blend filter in filter editor crashes

Bug #1795847 reported by basse on 2018-10-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
Mc

Bug Description

When you have simple filter, (like blend + gaussian blur) and you delete the bottom one (blend), Inkscape crashes. happens every time.

Backtrace is added as an attachment.

inkscape-trunk:
  Installed: 1:0.92.0+devel+201810021324~ubuntu18.04.1

.b

basse (basse) wrote :
Alvin Penner (apenner) wrote :

- reproduced on Windows 10, Inkscape 0.92+devel (33cd18d, 2018-10-02)
- not reproduced on Windows 10, Inkscape 0.92.3 (90c76b1, 2018-10-02)

backtrace:
Program received signal SIGSEGV, Segmentation fault.
0x01714183 in libinkscape_base!_ZN8Inkscape3XML14SignalObserver3setEP8SPObject ()
   from c:\app\temp\inkscape_devel\libinkscape_base.dll
(gdb) bt
#0 0x01714183 in libinkscape_base!_ZN8Inkscape3XML14SignalObserver3setEP8SPObject ()
   from c:\app\temp\inkscape_devel\libinkscape_base.dll
#1 0x014e2dcc in libinkscape_base!_ZN8Inkscape2UI6Dialog19FilterEffectsDialog13PrimitiveList30on_primitive_selection_changedEv
    () from c:\app\temp\inkscape_devel\libinkscape_base.dll
#2 0x00000000 in ?? ()
(gdb) c
Continuing.

Program received signal SIGSEGV, Segmentation fault.
0x01714183 in libinkscape_base!_ZN8Inkscape3XML14SignalObserver3setEP8SPObject ()
   from c:\app\temp\inkscape_devel\libinkscape_base.dll
(gdb) c
Continuing.
[Inferior 1 (process 8488) exited with code 030000000005]

Changed in inkscape:
status: New → Confirmed
Mc (mc...) wrote :
Changed in inkscape:
status: Confirmed → Fix Committed
importance: Undecided → High
assignee: nobody → Mc (mc...)
milestone: none → 1.0
basse (basse) wrote :

ok,
tried with todays update:
inkscape-trunk:
  Installed: 1:0.92.0+devel+201810081331~ubuntu18.04.1

still crashes.. but, could be ofcourse that it's not included in this one yet, I don't know how the ppa buildsystem works. I keep checking out. thanks.

.b

Alvin Penner (apenner) wrote :

I am no longer able to reproduce this bug in Inkscape 0.92+devel (4896f8c, 2018-10-08)

Qantas94Heavy (qantas94heavy) wrote :

Fix released with Inkscape 0.92.4.

Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments