Crash in cairo when batch exporting to pdf

Bug #1793253 reported by Konrad Rzepecki on 2018-09-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
Unassigned

Bug Description

Inkscape crash in cairo when I try run following command:

inkscape test.svg --export-pdf=./test.pdf
inkscape: cairo-recording-surface.c:2036: _cairo_recording_surface_replay_internal: Assertion `_cairo_int_status_is_error (status)' failed.

Reduced test case files are attached to this bug report (probably it can be reduced even more).

Most likely this is connected with embedded file using <use> and transformation in this element.

My system is Slackware-current:
Inkscape 0.92.2 2405546, 2018-03-11 (poppler patched)
cairo 1.15.12
cairomm 1.12.2

Konrad Rzepecki (labinnah) wrote :
Konrad Rzepecki (labinnah) wrote :
Alvin Penner (apenner) wrote :

not reproduced on Windows 10, Inkscape 0.92.3 (2405546, 2018-03-11)

I simply get the following error message:
** (inkscape.exe:2744): WARNING **: Can't get document for referenced URI: ./z.svg#top

Since I am on Windows, it is to be expected that this would not work, so I have also tried other variations such as xlink:href="z.svg#top" but they yield the same result.

On Windows I do not have any software that is capable of successfully opening this file, outside of Inkscape. Could you indicate which software you are using to open this file?

Konrad Rzepecki (labinnah) wrote :

My inkscape open this z.svg file. You can try chrome(ium) or firefox.
But contents of this file is rather irrelevant. This file only must have some path element, id="top" and no "width & height" in svg element.

If you ask about test.pdf, I can also open it in my inkscape. But it origin is from generator I currently wrote. But how this file looks is also irrevelant - this is only reduced test case which cause crash.

BTW. I'm quite sure I have inkscape 0.92.3 but it claims it is 0.92.2. I've build it from 0.92.3 tar.bz2 source from your website - problem in versioning code/wrong source package??? Build number seems to be like yours...

Patrick Storz (ede123) wrote :

Confirmed on Windows 10 with
- Inkscape 0.92.3 (98b32c4a03, 2018-09-15)
- Inkscape 0.92+devel (05291f649e, 2018-09-15)
in an MSYS2 environment (which handles the conversion from POSIX-style paths).

Not sure if we support non-local IRI references but in any case Inkscape should not crash.

Changed in inkscape:
status: New → Confirmed
importance: Undecided → High
Konrad Rzepecki (labinnah) wrote :

Little update, crash didn't occur when angle in transformation rotation is 90 degrees multiplier. Ie:

transform="rotate(89, 50, 50)" - crash
transform="rotate(90, 50, 50)" - OK
transform="rotate(91, 50, 50)" - crash

So most likely problem is somewhere in free(non symmetrical) rotation code.

Mc (mc...) wrote :

I would report this bug to cairo.
Since they use a sigabrt, I could not catch it with a try/catch, and listening for the ABRT signal() is what we already do for the emergency save.

Konrad Rzepecki (labinnah) wrote :

Did you report this on cairo? I'm unable to found appropriate entry nor on old nor new cairo bugzilla. If so, can you paste link to it?

If not, would you like to me to do it? I can, but I think you know how cairo is used in this case and you will create better report than I...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers