Inkscape: A Vector Drawing Tool

Openclipart file type import

Reported by erwan-yves on 2007-12-29
28
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
Unassigned
openclipart
Undecided
Unassigned
inkscape (Debian)
Fix Released
Unknown
inkscape (Ubuntu)
Undecided
Unassigned

Bug Description

When importing openclipart files, in a lot of case this is a bitmap version of the file (and not a svg type) which is imported.
Is it possible to know what type of file is going to be downloaded?

vonHalenbach (lustik) wrote :

In my opinion, imports from openclipart should only be in svg format. PNG or JPG are just there for preview and should not be imported into inkscape. Thank you for your bugreport.

Changed in inkscape:
importance: Undecided → High
status: New → Confirmed

I totally agree with you.
Only SVG should be imported
Best regards
Yves

2008/1/2, vonHalenbach <email address hidden>:
>
> In my opinion, imports from openclipart should only be in svg format.
> PNG or JPG are just there for preview and should not be imported into
> inkscape. Thank you for your bugreport.
>
> ** Changed in: inkscape
> Importance: Undecided => High
> Status: New => Confirmed
>
> --
> Openclipart file type import
> https://bugs.launchpad.net/bugs/179184
> You received this bug notification because you are a direct subscriber
> of the bug.
>

rejon (rejon) wrote :

Yes, absolutely.

Jon

On Wed, 2008-01-02 at 14:08 +0000, erwan-yves wrote:
> I totally agree with you.
> Only SVG should be imported
> Best regards
> Yves
>
>
> 2008/1/2, vonHalenbach <email address hidden>:
> >
> > In my opinion, imports from openclipart should only be in svg format.
> > PNG or JPG are just there for preview and should not be imported into
> > inkscape. Thank you for your bugreport.
> >
> > ** Changed in: inkscape
> > Importance: Undecided => High
> > Status: New => Confirmed
> >
> > --
> > Openclipart file type import
> > https://bugs.launchpad.net/bugs/179184
> > You received this bug notification because you are a direct subscriber
> > of the bug.
> >
>
--
Jon Phillips

San Francisco, CA
USA PH 510.499.0894
<email address hidden>
http://www.rejon.org

MSN, AIM, Yahoo Chat: kidproto
Jabber Chat: <email address hidden>
IRC: <email address hidden>

Please note: the contents of this email are not intended to be
legal advice nor should they be relied upon as or represented to be
legal advice. Jon Phillips does not represent any organization through
this email address.

pbhj (pbhj) wrote :

Yeah, what's the point of importing a PNG file?

If you're interested I have a (rather poor quality) screencast on YouTube of an import from OCAL: http://alicious.com/2008/videomovie-screen-capture-programs-for-ubuntu-linux/ if anyone wants the original OGG file, made with krecordmydesktop, then let me know.

kur9kin (kur9kin-yandex) wrote :

when looking at the details as to why this happens,
it becomes clear that the problem is not with inkscapes import-utility (which may have other flaws though).

The problem is in openclipart's implementation, and the bug might do more sense over there.
I haven't filed one yet myself, but I plan to.

Nevertheless, as long as this is the case, the 'import'-feature works so-so

Kattekrab (donna) wrote :

This is a useful feature. At the very least being able to search and browse openclipart inside inkscape is a time and productivity saver, but it would be much more useful if it imported the SVG.

Has anyone been able to resolve whether or not this depends on changes at openclipart.org before it can be fixed in Inkscape? I tried a quick search at the freedesktop/openclipart bugzilla but couldn't find it.

If this one can't be resolved for the 0.47 release, perhaps shift it back in to the experimental tree?

Antonio Roberts (hellocatfood) wrote :

I definitely think this should be solved soon. It's a great feature but would be good to have the option of svg or png only.

tags: added: ocal
removed: openclipart
Alex Valavanis (valavanisalex) wrote :

Here's an example of the problem from debbugs #568617:

file -> import from open clip art library
search firewall
select the second entry (this one
http://openclipart.org/media/files/Anonymous/12257 )
stretch it, see that it is the rasterized version

~suv (suv-lp) wrote :

@Alex - you can recognize whether it is a bitmap or SVG file before actually importing it into your document:
in the preview pane of the import dialog the size (H x W in px) is displayed in the upper left corner if it is a bitmap.

Antonio Roberts (hellocatfood) wrote :

@~suv

Good workaround, but it still doesn't solve the original problem of being able to specify to only import svgs.

I've tried writing a bug report on the OCAL website: https://bugs.freedesktop.org/show_bug.cgi?id=26657 if any developers can add anymore information please do

~suv (suv-lp) wrote :

@Alwx, Antonio - my tip was wrong! With the current feed that px sizes relate to the preview, not to the inserted clipart.

Open Clipart Library now serves only SVG.

Changed in inkscape (Ubuntu):
status: New → Confirmed
~suv (suv-lp) wrote :

Do you still see this issue with the _current_ feed of OpenClipart 2.0?

Alex Valavanis (valavanisalex) wrote :

@~suv,

You're correct... now, only SVG images are served by openclipart 2.0. I'll mark this as invalid in Inkscape, as the issue really lay with the openclipart.org service.

Changed in inkscape (Ubuntu):
status: Confirmed → Invalid
Changed in openclipart:
status: New → Fix Released
Changed in inkscape:
status: Confirmed → Invalid
pbhj (pbhj) wrote :

Actually, in response to ~suv, I can no longer get imports from the OCL instead the search reports:

"Failed to receive the Open Clip Art Library RSS feed. Verify if the server name is correct in Configuration->Import/Export (e.g.: openclipart.org)"

Verified the domain is correct and have logged in and checked and rechecked my credentials.

Could this be something on the OCL end as I note that their site is listed as "beta".

~suv (suv-lp) wrote :

@pbhj - strange, works for me (just tested again with 0.47 and 0.47+devel r9192).

> … have logged in and checked and rechecked my credentials.
? - you don't need login credentials to import from OpenClipart in Inkscape.

The same error was reported some days ago with openclipart, but has been fixed (2010-03-06) in the feed of OpenClipart 2.0 Beta, see bug #532070 in openclipart: “InkScape : no way tu import from openclipart” <https://bugs.launchpad.net/openclipart/+bug/532070>

Changed in inkscape (Debian):
status: Unknown → Fix Released
~suv (suv-lp) on 2010-07-05
tags: added: openclipart
removed: ocal

Hello Customer

Genuine luxury watches cost a fortune, cheap fakes you will find on the streets are of low quality.
No matter what you do with your watch, you will enjoy it.

-
FANTASTIC WATCH. 100% AS DESCRIBED. MY JEWELER COULD NOT TELL IT WAS NOT A REAL ROLEX. I HIGHLY RECOMMEND DOING BUSINESS WITH THIS SELLER.
Thank you very much
                     Kara Parra
-

Click here ---> http://vicea.ru

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.