This file makes Inkscape use all the ram when trying to open

Bug #1782099 reported by Filip Sund on 2018-07-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Unassigned

Bug Description

Trying to open the attached file using Inkscape results in massive RAM usage. I left it running for a while, but had to stop it at 12 GB.
The Inkscape window doesn't even show up, it's only visible in Task Manager.

The file was created just using Inkscape. I suspect the "Mirror symmetry" path effect might be the culprit.

Inkscape 0.92.3 (2405546, 2018-03-11), fresh Inkscape installation.
Windows 10, version 10.0.17134 (Build 17134)

Filip Sund (fsund) wrote :
description: updated
Alvin Penner (apenner) wrote :

- crash confirmed on Windows 10, Inkscape 0.92.3 (2405546, 2018-03-11) (32 bit)
- instead of massive RAM usage I got the crash message:

** (inkscape.exe:2092): WARNING **: Exception during LPE Mirror symmetry execution.
 std::bad_alloc
terminate called after throwing an instance of 'std::bad_alloc'
  what(): std::bad_alloc

Emergency save activated!
Emergency save completed. Inkscape will close now.
If you can reproduce this crash, please file a bug at www.inkscape.org
with a detailed description of the steps leading to the crash, so we can fix it.

Changed in inkscape:
status: New → Confirmed
Alvin Penner (apenner) wrote :

- crash not reproduced on Windows 10, Inkscape 0.92+devel (e33f40d, 2018-06-25)

Qantas94Heavy (qantas94heavy) wrote :

Can you still reproduce this issue with Inkscape 0.92.4?

I can't reproduce this crash on Windows 10, Inkscape 0.92.4 (5da689c313, 2019-01-14) 64-bit. Memory used is only about 76 MB.

Changed in inkscape:
status: Confirmed → Incomplete
Filip Sund (fsund) wrote :

Agreed, I don't have any issues on Windows 10, Inkscape 0.92.4 (5da689c313, 2019-01-14) 64-bit (msi installer).

Qantas94Heavy (qantas94heavy) wrote :

Closing as fixed in 0.92.4. If this is not the case, please reopen or file a new bug here: https://inkscape.org/report. Thank you!

Closed by: https://gitlab.com/Qantas94Heavy

Changed in inkscape:
milestone: none → 0.92.4
status: Incomplete → Fix Released
tbnorth (terry-n-brown) on 2019-11-29
tags: added: bug-migration
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers