Complex object ungrouping

Bug #177751 reported by Wahooney on 2007-12-20
10
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Mc

Bug Description

I have a group that consists of:

    * 1x Text Object
    * 1x Linked Offset (from Text Object)
    * 1x Clone of Linked offset (blurred for drop shadow)
    * 1x Clone of Text Object clipped by a path

Now when I try to ungroup that group the whole lot explodes into pieces which are randomly scattered around.

nightrow (jb-benoit) wrote :

Thank you for taking the time to report this bug and helping to make Inkscape better.
As you seems to have a rather precise problem, could you please attach you .svg for us to work with ?
It is also always usefull to tell what version of inkscape you are using and on which platform.

Changed in inkscape:
importance: Undecided → Medium
status: New → Incomplete
Wahooney (wahooney-wahooney) wrote :

I've attached the file.

I'm using the latest Win32 Build (Inkscape0712181705.7z). And it seems pretty consistent so far.

Thanks.

prkos (prkos) wrote :

The problem can be simplified; the issue is Linked offset. I don't know how that feature should work so I can't tell if this is a bug or normal behavior.

Its easy to reproduce:
1. create a text object
2. go to Path > Linked Offset (Ctrl+Alt+J)
(3. optional: drag the handle to make a bigger offset and change fill color so you can see it right away)
4. select both objects
5. group them
6. move group
7. ungroup

The offset object isn't center aligned anymore, and the further the group had been moved, the greater the distance between the objects. The preferences in Inkscape Preferences > Clones don't seem to matter

Attached a simple file, only the final step hasn't been made so just ungroup and see the result

Im on WinXP build 18th Dec

Thomas Hicks (hicks-kingtom) wrote :

Can confirm the problem. The basic problem is that the transform attribute gets applied twice to the linked offset.

Workaround: Set: Inkscape Preferences -> Transforms -> Store transformation to: Preserved
instead of Optimized

Changed in inkscape:
status: Incomplete → Confirmed
prkos (prkos) wrote :

I can confirm that Inkscape Preferences > Transforms > Preserved eliminates the problem. Does that mean that this is expected behavior and not a bug?

Related to bug 167419

Wahooney (wahooney-wahooney) wrote :

I tried the Optimized vs Preserved transforms on the test.svg I attached and although it reduces the problem it doesn't eliminate it as the clipped object's 'sub-objects' still bug out.

I have encountered this same problem when working on a simple finite state machine diagram, but I didn't use any linked offsets. The closest I did to that was duplicating some objects rather than creating new ones from scratch. I do have some text-on-path objects. Those are the ones getting strewn about.

sas (sas-sas) wrote :

nitrogen, your problem appears to be a different one: bug 168286

When ungrouping, the linked offsets now stay where they are. That I just fixed (as of rev. #21633). The clipped path however is still misbehaving and moves away; this looks like a similar issue, but I haven't yet been able to pin-point it.

tags: added: groups
removed: ungroup
insaner (insaner) wrote :

I cannot reproduce with Inkscape 0.91+devel r14032 on fc16 linux using the attached file (test.svg). Neither Optimized nor Preserved options cause a difference in behavior.

jazzynico (jazzynico) wrote :

Tested again on Windows XP (32 bit).
Clipped path not fixed with 0.48.5, 0.91 and trunk rev. 13331.
Everything works as expected with trunk rev. 14221.

Changed in inkscape:
milestone: none → 0.92
status: Confirmed → Fix Committed
su_v (suv-lp) wrote :

Based on tests with archived trunk builds, the remaining issue was fixed in rev 13925.
Fix was backported to 0.91.x AFAICT in rev 13766.

The test case from comment #2 ungroups without unexpected displaced objects with 0.91.x r13826.

Changed in inkscape:
assignee: nobody → Mc (mc...)
milestone: 0.92 → 0.91.1
jazzynico (jazzynico) on 2017-01-28
Changed in inkscape:
milestone: 0.91.1 → 0.92
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers