invalid conversion from ‘const GooString*’ to ‘GooString*’

Bug #1766719 reported by Alan Aversa on 2018-04-24
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
Patrick Storz

Bug Description

I get the following error when trying to build Inkscape 0.92.3 on
Slackware-current:

      CXX extension/internal/filter/filter-all.o
    extension/internal/pdfinput/pdf-parser.cpp: In member function ‘void
    PdfParser::opShowText(Object*, int)’:
    extension/internal/pdfinput/pdf-parser.cpp:2493:31: error: invalid
    conversion from ‘const GooString*’ to ‘GooString*’ [-fpermissive]
       doShowText(args[0].getString());
                  ~~~~~~~~~~~~~~~~~^~
    In file included from extension/internal/pdfinput/pdf-parser.cpp:36:0:
    extension/internal/pdfinput/pdf-parser.h:290:8: note: initializing
    argument 1 of ‘void PdfParser::doShowText(GooString*)’
       void doShowText(GooString *s);
            ^~~~~~~~~~
    extension/internal/pdfinput/pdf-parser.cpp: In member function ‘void
    PdfParser::opMoveShowText(Object*, int)’:
    extension/internal/pdfinput/pdf-parser.cpp:2514:31: error: invalid
    conversion from ‘const GooString*’ to ‘GooString*’ [-fpermissive]
       doShowText(args[0].getString());
                  ~~~~~~~~~~~~~~~~~^~
    In file included from extension/internal/pdfinput/pdf-parser.cpp:36:0:
    extension/internal/pdfinput/pdf-parser.h:290:8: note: initializing
    argument 1 of ‘void PdfParser::doShowText(GooString*)’
       void doShowText(GooString *s);
            ^~~~~~~~~~
    extension/internal/pdfinput/pdf-parser.cpp: In member function ‘void
    PdfParser::opMoveSetShowText(Object*, int)’:
    extension/internal/pdfinput/pdf-parser.cpp:2537:31: error: invalid
    conversion from ‘const GooString*’ to ‘GooString*’ [-fpermissive]
       doShowText(args[2].getString());
                  ~~~~~~~~~~~~~~~~~^~
    In file included from extension/internal/pdfinput/pdf-parser.cpp:36:0:
    extension/internal/pdfinput/pdf-parser.h:290:8: note: initializing
    argument 1 of ‘void PdfParser::doShowText(GooString*)’
       void doShowText(GooString *s);
            ^~~~~~~~~~
    extension/internal/pdfinput/pdf-parser.cpp: In member function ‘void
    PdfParser::opShowSpaceText(Object*, int)’:
    extension/internal/pdfinput/pdf-parser.cpp:2575:31: error: invalid
    conversion from ‘const GooString*’ to ‘GooString*’ [-fpermissive]
           doShowText(obj.getString());
                      ~~~~~~~~~~~~~^~
    In file included from extension/internal/pdfinput/pdf-parser.cpp:36:0:
    extension/internal/pdfinput/pdf-parser.h:290:8: note: initializing
    argument 1 of ‘void PdfParser::doShowText(GooString*)’
       void doShowText(GooString *s);
            ^~~~~~~~~~
    extension/internal/pdfinput/pdf-parser.cpp: In member function ‘void
    PdfParser::opXObject(Object*, int)’:
    extension/internal/pdfinput/pdf-parser.cpp:2735:31: error: invalid
    conversion from ‘const char*’ to ‘char*’ [-fpermissive]
       char *name = args[0].getName();
                    ~~~~~~~~~~~~~~~^~
    make[3]: *** [Makefile:9106:
    extension/internal/pdfinput/pdf-parser.o] Error 1
    make[3]: *** Waiting for unfinished jobs....
    extension/internal/pdfinput/svg-builder.cpp: In member function
    ‘void Inkscape::Extension::Internal::SvgBuilder::updateFont(GfxState*)’:
    extension/internal/pdfinput/svg-builder.cpp:1023:58: error: invalid
    conversion from ‘const char*’ to ‘char*’ [-fpermissive]
             _font_specification = font->getName()->getCString();
                                   ~~~~~~~~~~~~~~~~~~~~~~~~~~~^~
    make[3]: *** [Makefile:9106:
    extension/internal/pdfinput/svg-builder.o] Error 1
    make[3]: Leaving directory '/tmp/SBo/inkscape-0.92.3/src'
    make[2]: *** [Makefile:5977: all] Error 2
    make[2]: Leaving directory '/tmp/SBo/inkscape-0.92.3/src'
    make[1]: *** [Makefile:1473: all-recursive] Error 1
    make[1]: Leaving directory '/tmp/SBo/inkscape-0.92.3'
    make: *** [Makefile:1129: all] Error 2

I'm using:

poppler-0.64.0-x86_64-1alien
poppler-data-0.4.8-noarch-2

Patrick Storz (ede123) wrote :

This is caused by an incompatible change in poppler 0.64.

Incidentally I just committed a fix to master a few hours ago:
  https://gitlab.com/inkscape/inkscape/commit/a600c6438fef2f4c06f9a4a7d933d99fb054a973

You can either downgrade poppler or apply the fix from master to 0.92.3 (it should apply cleanly).
If no issues are found I'll commit the patch to 0.92.x eventually.

tags: added: build
Changed in inkscape:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Eduard Braun (eduard-braun2)
milestone: none → 0.92.4
Bryce Harrington (bryce) on 2019-01-18
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers