Tiny version bug

Bug #1759620 reported by oldpink on 2018-03-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
Mc

Bug Description

I was happy to see that a new version of Inkscape was available, so I dutifully built, then installed it, launching the program to see how it performs.
One tiny thing I noticed right off is that it reports the version as 0.92.2, even though the source is most definitely for 0.92.3.
A quick bit of checking around indicated that the fix the version correct looked ridiculously simple, and a rebuild with the attached patch and relaunch to check the version confirmed that I was correct.
Of course, this is a very minor issue, but I'm sure that you want the proper version to display from the Help -> About window.
Thanks for creating and maintaining such an excellent program that I have been using for nearly ten years straight now.

Mc (mc...) wrote :

Thanks^^
The reason for this bug is that we don't use autotools to build but cmake so this has escaped our attention (but we still plan to maintain autotools for the 0.92.x branch, so it's a valid problem)

Fix committed in https://gitlab.com/inkscape/inkscape/commit/d2272d93fce0df80d2cbf5b17af9d8f6cf074edb , not sure if we need a new release tarball ?

Changed in inkscape:
importance: Undecided → Low
assignee: nobody → Mc (mc...)
milestone: none → 0.92.3
status: New → Fix Committed
oldpink (misassistant) wrote :

You're welcome.
I'm a Slackware guy, and the SlackBuild still uses autotools, so that's how I build nearly all of my packages.

Bryce Harrington (bryce) on 2018-05-12
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers