Wishlist: crash message that can be copy-pasted into a bug report

Bug #1759588 reported by Hachmann on 2018-03-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Wishlist
Unassigned

Bug Description

Just read about improvements in Gimp on pro-linux, and I think something like this could make bug reporting a lot more painless for users and speed up bug triage:

https://www.pro-linux.de/images/NB3/imgdb/o_debug-dialog-in-gimp-210.jpg

The dialog contains instructions for:

- where to report the bug with clickable link
- in which language to report the bug

And info about:

- the libraries used
- a traceback
- possibly: version numbers, OS (not visible on screenshot)

Hachmann (marenhachmann) on 2018-03-28
description: updated
Patrick Storz (ede123) wrote :

Great idea!

One thing somewhere in the middle of my ever-growing todo list is to to add a button to the "About" dialog to "copy version information", but having it directly in crash dialog is an even better way.

Do you know what information is added to these crash logs except version numbers?

Obviously it would help if we could gather actual information on the crash (e.g. console output and maybe even some sort of backtrace) as the crash dialog itself is not helpful without detailed steps to reproduce). I'm not sure if there is a possibility to do this in a platform-independent way, if there was it would greatly simplify reporting useful bugs for users.

Hachmann (marenhachmann) wrote :

I think having both - most important info for copying (maybe in the About dialog?) and some info in the crash dialog - would be useful. Many bugs are not crashes, fortunately.

As for the info - I don't know any more than what is on the screenshots. I didn't compile it and try to find a way to make the new gimp crash ;-) (nor read their source code for it).

Patrick Storz (ede123) wrote :

Just found the following article via GIMP 2.10.0 RC1 news item:
https://girinstud.io/news/2018/02/automatic-bug-report-stack-traces-gimp/

It might just have all the information needed to make this work in Inkscape, too.

In fact a proper backtrace seems to be attached for all common platforms!

Changed in inkscape:
importance: Undecided → Wishlist
status: New → Triaged
Hachmann (marenhachmann) wrote :

Cool - thanks for investigating, Eduard :-D

Qantas94Heavy (qantas94heavy) wrote :

Hi there, it seems we now have a similar request on our new GitLab bug tracker. Please follow there for all future updates. Thank you!

Moved to: https://gitlab.com/inkscape/inkscape/issues/81
Closed by: https://gitlab.com/Qantas94Heavy

Changed in inkscape:
status: Triaged → Invalid
tags: added: bug-migration
Hachmann (marenhachmann) wrote :

Reopening, as the author of the report explained today that these bugs are not the same.

Changed in inkscape:
status: Invalid → New
tags: removed: bug-migration
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.