Documentation consistency: create / use a preferences.xml for documentation creation

Bug #1735305 reported by Hachmann on 2017-11-29
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Patrick Storz

Bug Description

To make documentation creation (foremost SVG files for tutorials) more consistent across multiple devices (and have cleaner version control diffs), we could use a separate preferences.xml when creating the tutorial files.

Patrick Storz (ede123) wrote :

Did you have any specifics in mind?

From my point of view loading a default preferences.xml (or point to an empty use folder) should already be enough.

The only thing I considered for creating cleaner diffs was sorting attributes but as we run all SVG files through Scour anyway, that's actually unnecessary.

Comparing tutorials created via CI and tutorials on my machine (MSYS2/Windows 10; actually with my personal preferences):
- document structure / style attributes are identical
- there are a lot of differences which seem to be caused by rounding
  and slightly different font rendering between OSs
  (an accumulated .8px in y-direction to be precise)
- object IDs are not constant for some reason
  (I'd need to look into Scour code to figure out why)

Hachmann (marenhachmann) wrote :

I don't really remember which differences triggered this report.

I know we can get significant differences in file output when it comes to absolute/relative/optimized path data saving, transforms and precision, as well as named colors, and icc-colors, but that might be fixed by scour - you'll know that better than I do.

Patrick Storz (ede123) wrote :

absolute/relative/optimized path data saving, transforms and precision, as well as named colors are all handled by scour (and we control those settings already), icc-colors I have never but I guess they are not relevant while saving the vector data.

Ideally we'll have published tutorials built exclusively by CI anyway, so differences between executions should be minimal as we always start with a clean VM anyway.

I'll look into the IDs (it's nothing serious but if it's easily fixable why not go for it...).
If you notice anything else let me know.

Patrick Storz (ede123) wrote :

Using a clean profile is now implemented:
  https://gitlab.com/inkscape/inkscape-docs/documentation/commit/54010fc9bfbd14fc35eb6fceb403fb9b264c040b

Comparing files for consecutive CI runs (as well as consecutive runs on my machine) results in identical SVG tutorials, so basically the case we were hoping for.

The variable IDs I noted before seem to be caused by differences in Python itself between the OSs (Scour versions are identical, as are Python versions). I therefore tend to put this on hold for now. In practice this difference should not matter for us (probably for nobody else either).

Changed in inkscape:
assignee: nobody → Eduard Braun (eduard-braun2)
status: New → Fix Committed
milestone: none → 0.92.3
Hachmann (marenhachmann) wrote :

Great, thank you!

Bryce Harrington (bryce) on 2018-05-12
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers