92.2 Replace Color Extension not working on pattern

Bug #1733657 reported by Brenda Collins on 2017-11-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Unassigned

Bug Description

I just updated to Inkscape 92.2 and I am having problems with the "Replace Color" extension. I use it frequently to change color on fill patterns and when I tried to recolor a pattern in 92.2 it would not work.

My workflow used is as follows:

Create shape with rectangle tool
Apply "wavy pattern" to shape
With shape selected open Replace Color Extension
Enter 000000 for current color and enter new color (48d1cc)
Nothing happens

I do see the working, please wait popup flash by and disappear in an instant but it does not stay up and then nothing happens and my pattern remains black. I tried with a few other patterns and shape sizes but none of them changed color.

I had to go back to my Inkscape .91 and replace the color in my shape, export it as a png (which is what I needed) and then reopen it in 92.2

So far 92.2 seems more stable than .91 or .92 so I would like to continue using it without having to jump between versions to recolor objects/patterns which I use frequently. Is there something I am missing or doing wrong in the new version? It works fine in my Inkscape .91.

Thanks again for all your hard work, I am a longtime Inkscape lover! I use it to create label designs for my Bath and Body products and nothing can touch the power it has combining a text with shape design!

Brenda Collins
Inkscape 92.2 64-bit
Windows 7 Home Premium
Sony Viao Laptop 2.4 Ghz. 4Gb RAM

Eduard Braun (eduard-braun2) wrote :

Hi Brenda, this issue was discovered before and will be fixed in Inkscape 0.92.3, see bug #1720330.

If you like you can try a nightly build of the stable branch which should solve your issue, the most recent is
https://ci.appveyor.com/project/inkscape/inkscape/build/0.92.x-684/job/gxy4oe6r90ka37gs/artifacts

(It does not come with an installer but only packed as .7z archive; simply extract it to an empty folder and run it from there)

tags: added: extensions-plugins
removed: color replace
Eduard Braun (eduard-braun2) wrote :

Sorry, I spoke to fast... I just realized "Replace color" is not a raster extension, so the linked bug does not apply here.

Eduard Braun (eduard-braun2) wrote :

I just checked on my machine (Windows 7 x64) with a recent build of 0.92.x branch (b2fd37f, 2017-10-23) and "Replace color" works flawlessly.

One thing that could cause this type of problem is a faulty Inkscape installation (as we changed some things internally for 0.92.2 leftover files of a previous installation often cause issues).

Could you try to completely uninstall Inkscape and then install into an empty directory (either pick a new installation directory or make sure to delete any potential leftovers from the previous installation directory prior to installation)?

Brenda Collins (gentlebath) wrote :

Thanks and I will try to reinstall. 92.2 was however already installed in a new directory. I still hVe .48 and .91 on my machine all in their own directory just for instances like this where I need to finish a project but the new version has a hiccup.

I go back to an earlier version where I know the feature works. The strange thing with this one is that it this was a brand new file too created in the new version. Oh well, I will still try and reinstall. A reboot still seems to resolve most problems I encounter these days so a reinstall is no biggie just to make sure.

Brenda Collins (gentlebath) wrote :

Success! A reinstall fixed it and I was able to replace the color in a pattern on the first try!

I don't know if this matters but my first install was not in the Programs(86x) directory but in my user directory. I'm not sure how that happened but could that be a factor in it not working? I'm not a programmer, just a user so I not sure it that matters or not.

Thanks again for the suggestion! It was a very easy fix and I look forward to seeing all the 92.2 offers!

Eduard Braun (eduard-braun2) wrote :

Usually it *should* be fine. If the path to your user directory contains any special characters it might be an issue, though.

Changed in inkscape:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers