after ungroup font-size is removed

Bug #1733651 reported by Johannes Kalliauer on 2017-11-21
30
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Patrick Storz

Bug Description

If you ungroup <g font-size="x"><text>some text</text></g> element in Inkscape 0.92.2 (Ubuntu 16.04 and on Windows 7 and 10) the font-size is removed.

exmaple:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE svg PUBLIC '-//W3C//DTD SVG 1.1//EN' 'http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd'>
<svg version="1.1" viewBox="0 0 900 900" xmlns="http://www.w3.org/2000/svg">
 <g font-family="Times" font-size="200">
  <text x="0" y="500">$\sigma$</text>
  <text x="0" y="200" xml:space="preserve">$\tau^<tspan dy="-52" font-size="118">{max}</tspan><tspan dy="52"> </tspan>$</text>
 </g>
</svg>

summary: - after ungroup font-size not correct
+ after ungroup font-size is removed
Alvin Penner (apenner) wrote :

confirmed on Windows 10, Inkscape 0.92.2 (5c3e80d, 2017-08-06)

Changed in inkscape:
status: New → Confirmed

example were ungroup removes font-size

@su_v
@suv-lp
Can you add the Importance and the milestone from duplicate bug https://bugs.launchpad.net/inkscape/+bug/1518575

tags: added: regression
removed: groups

confirmed on Windows 10, Inkscape 0.92.3 (2405546, 2018-03-11)

Patrick Storz (ede123) wrote :
Changed in inkscape:
assignee: nobody → Patrick Storz (ede123)
status: Confirmed → Fix Committed
importance: Undecided → Medium
milestone: none → 0.92.4

@ede123
@Patrick Storz

How can I get the latest inkscape-thrunk with the fixed bug? (for Windows 10 and/or for Ubuntu 18.04)

Do I have to build it like described here?
https://gitlab.com/inkscape/inkscape/blob/master/INSTALL.md

Or is there also a executable?

I need this feature quite offten, since 1 made more than 1000 workarounds for https://phabricator.wikimedia.org/T36947 using ungrouping by Inkscape.

@ede123
@Patrick Storz

How can i get the newest version with the bug resolved?

Are there any executable to install (Win10 or/and Ubuntu 18.04) or do I have to build it from source on my own? Where do I get those installation-files?

Hachmann (marenhachmann) wrote :

@jokalliauer1989 Visit https://inkscape.org/release/master and follow the instructions for the operating system of your choice.

@ede123
Thanks, but now it still does not work for

 <g font-family="DejaVu Sans" text-anchor="middle">
  <text transform="scale(10)"><tspan x="108.73" y="71.2" font-size="2.66">Гуанхауто</tspan></text>
 </g>

because after ungrouping (leads to a removement of transform) it should have font-size="26.6" instead of font-size="2.66".

https://bugs.launchpad.net/inkscape/+bug/1802153

Bryce Harrington (bryce) on 2019-01-18
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments