Inkscape: A Vector Drawing Tool

Crash when moving object

Reported by JiHO on 2007-11-29
2
Affects Status Importance Assigned to Milestone
Inkscape
Critical
Unassigned

Bug Description

As of rev 16565 moving the object in the attached file crashed Inkscape every time. I thought it was related to grid problems or snapping so I disabled the grid and all snapping options and it still crashes.

JiHO (jiho) wrote :
Changed in inkscape:
importance: Undecided → Critical
JiHO (jiho) wrote :

Does not occur with older rev 16467.

Maximilian Albert (cilix) wrote :

Cannot reproduce in latest revision #16571. Could you please try with latest SVN head and see if it still persists? This seems very much like bug #172582, which was fixed by Johan Engelen in revision #16569.

JiHO (jiho) wrote :

I does not occur with latest svn (16571) indeed. Sorry not to have double checked but I thought it was not the same that bug #172582 since I disabled all snapping and it persisted. If it was the same then there's another issue: snapping code was called even when snapping was switched of.
I tried to run rev 16565 in gdb but since I removed debug symbols, the message is not very informative:
Program received signal EXC_BAD_ACCESS, Could not access memory.
Reason: KERN_PROTECTION_FAILURE at address: 0x00000000

I close this one and will add a new one if necessary about the issue above.

Changed in inkscape:
status: New → Fix Released

As reported in bug #172808, this seems to be the same bug indeed,
which leads to the conclusion that snapping code is called when it
should not need to be. That's why I opened a new bug report.

I did some testing before I committed this code, but couldn't get it to crash with empty strings. You succeeded however, so apparently you are more much capable in getting Inkscape to surrender ;-)

Johan has already fixed this, but I was also already working on this code to get it replaced by something more robust. You can expect some updates tonight.

Diederik

I don't know if this is exactly the same issue, but it looks like a regression.
I'm having a consistent crash with a file that contains a pasted group from other inkscape instance (it doesn't crash in the original instance).
The file doesn't crash in 0.46 but it does in SVN
Unfortunately I can't get a backtrace from gdb because when the file crashes it hangs the input of the mouse pointer too, and I can't change to the terminal window to get the backtrace (maybe is it possible to do that with other method, but I don't know how to do it).
I'm attaching the offending file.

Changed in inkscape:
status: Fix Released → Confirmed

This file crashes inkscape when I try to move the group.
Ubuntu 8.10 - 64 bit.
Inkscape SVN

(it doesn't crash in 0.46)

bbyak (buliabyak) wrote :

confirmed, this is a 2geom crash:

  what(): lib2geom exception: domain parameter out of range
(./2geom/hvlinesegment.h:476)

Johan updated 2geom and the provided file doesn't crash anymore.
Marking as fixed.

Changed in inkscape:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers