Higher Precision Doc size and Clone tool

Bug #171980 reported by Tjvigil66 on 2007-06-04
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Wishlist
Johan Engelen

Bug Description

Objects and nodes can be located to the 0.000 decimal place. Grids and
guides can only be located to the 0.00 decimal place.

Why do grids and guides only have a 0.00 precision?

Grids and Guides fixed, Document size and Clone tool to go.

Tjvigil66 (tjvigil66) wrote :

Originator: YES

I should point out that the Clone tool is also only precise to 0.00
instead of 0.000!

Bug Importer (bug-importer) wrote :

I'd like to see 0.000 precision for document size as well.

Ryan Lerch (ryanlerch) on 2007-12-13
Changed in inkscape:
importance: Undecided → Wishlist
status: New → Confirmed
Maximilian Albert (cilix) wrote :

Guides have 3 digits precision since revision 16113 (dating from 2007-09-21). Grids even have 4 digits of precision in current SVN (rev 16680).
This narrows this RFE down to providing 3-digit precision in Clone tool and for document size.

prkos (prkos) on 2008-10-26
description: updated
Drak (drakken-mordith) wrote :

Can this be bumped up from 'Wishlist' to a higher priority?

For professional printing this can be a problem for document sizes with only 2 points of precision. Converting a document size of 3.75" x 2.25" to .pdf results in 3.76" x 2.26" which causes issues.

Thanks!

su_v (suv-lp) on 2011-02-15
tags: added: preferences ui
Changed in inkscape:
status: Confirmed → Triaged
ScislaC (scislac) on 2011-06-15
Changed in inkscape:
assignee: nobody → Jon A. Cruz (jon-joncruz)
Johan Engelen (johanengelen) wrote :

I just gave you 5 digits behind the comma in the document settings dialog :P

Johan Engelen (johanengelen) wrote :

I increased the significant digits in document size and clone tile dialogs. Hopefully satisfying.

Changed in inkscape:
assignee: Jon A. Cruz (jon-joncruz) → Johan Engelen (johanengelen)
milestone: none → 0.49
status: Triaged → Fix Committed
John Smith (john-smithi) on 2012-08-28
tags: added: precision
su_v (suv-lp) wrote :

@Johan - any chance you could take a look at the inconsistency described in this follow-up report?
- Bug #1076428 “Document size (mm) won't stay precise size”
  <https://bugs.launchpad.net/inkscape/+bug/1076428>
(based on my quick tests it seems to be a side-effect of the additional significant digits added in the GUI)

Bryce Harrington (bryce) on 2015-02-21
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers