Default filename in "Save as" dialog

Bug #171932 reported by Yfarjoun on 2007-05-11
16
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Unassigned

Bug Description

When working with multiple files the "Save as" dialog has a peculiar
behavior: It suggests to use the file name that I previously saved as for
the current save. Since "save as" is usually used to change the type of the
file (rather than the filename) the default should be to use the base name
of the current file and the last "save as" file-type.

To reproduce:

1. open file a.svg
2. save as a.tex (pstricks)
3. open file b.svg
4. try to save as

outcome: "save as" dialog suggests a.tex

desired outcome: dialog suggests b.tex

of course .tex (pstricks) is arbitrary, same should be for all file types
and extensions.

xylo (stefan-endrullis) wrote :

I totally agree with you. It's nasty to check what file you're currently editing and retype the filename or select the file again, only to get the filename of the current document.

Same for the "Save a Copy..." dialog.

Ryan Lerch (ryanlerch) on 2008-01-21
Changed in inkscape:
importance: Undecided → Medium
status: New → Confirmed
Maximilian Albert (cilix) wrote :

Fixed in SVN as of rev. 22033. Please test.

Changed in inkscape:
status: Confirmed → Fix Released
Dženan Zukić (dzenanz) wrote :

It seems that this bug has resurfaced in 0.47pre4, Oct 12 2009. On WinXP, there is no suggested name in save as dialog, just as in save a copy dialog.

Changed in inkscape:
status: Fix Released → New
su_v (suv-lp) wrote :

WFM with Inkscape 0.46+devel r22544 on OS X 10.5.8 (uses the GtkFileChooser)

jazzynico (jazzynico) wrote :

Confirmed on Vista, Inkscape revision 22536.
"Save as" never suggests anything (except the .svg file extension).

Changed in inkscape:
status: New → Confirmed
zuhans (zuhansh) wrote :

confirmed in 0.47.
no suggestions is done.

and: I would like that only the filename (not extension) is inserted by default: it is irritating if I have "test.svg" in first line and change beneath to "pdf" - must I now correct the line above, does it inkscape for me or do I end up in having "test.svg.pdf"?

greetings
zuhans

xylo (stefan-endrullis) wrote :

But omitting the file extension could be also irritating. Most of the applications I use do not append the file extension automatically to the filename. I don't know if Inkscape does this already, because I always chose "Guess from extension" as file format. And in this case the extension is essential.

LucaDC (dicappello) wrote :

I work under Windows XP.
If you "Save a copy..." of a .svg file changing its format to PDF the file is created with the correct extension, also if you leave the name with a .svg extension (i.e. if you save file.svg as PDF you will find file.pdf also without manually changing its name). I've checked once and now regularly do this to save time.

So, Inkscape already replaces (when needed) the old extension with the new one; what's missing is an immediate update of the filename field in the save dialog as soon as you change the format.

Beluga (buovjaga) wrote :

Still repro.

Arch Linux 64-bit, KDE Plasma 5
Inkscape 0.91 r13725

jazzynico (jazzynico) on 2016-08-12
tags: added: ui
removed: ui-dialogs-toolbars
Changed in inkscape:
status: Confirmed → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers