Subscript/Superscript support

Bug #171886 reported by Bug Importer on 2007-04-14
This bug report is a duplicate of:  Bug #170324: subscript, superscript. Edit Remove
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Inkscape
Wishlist
Unassigned

Bug Description

Currently the only way to generate subscript and superscript is with manual vertical kerning and resizing of text spans, but this is tedious and hard to keep consistent across text areas.

Request is for the ability to toggle super/subscript (possibly by implementing the 'baseline-shift' SVG element) using a toolbar button..

Original bug description (invalid)--follows:
[At present (0.45), text strings can have attributes applied only to the
whole text object. However, it is useful to allow subscripts or
superscripts, or to allow bold or italic modifiers on substrings within the
same text object. For example, it may be necessary to indicate the area of
an object in m² or to refer to coordinates as z1, etc.]

O--b (o--b) wrote :

Originator: NO

AFAIK, this is already available in current inkscape versions:
with the text tool, span the piece of text you want to modify. Hit the B
or I button, turns bold or italics. You can also change it's size with the
usual drop-down box. And it's vertical position with Alt+arrows: everything
you need for subscript/superscript. However, reproducing exactly the same
properties on each and every superscript string in your text can prove
cumbersome: As Ctrl+c/Ctrl+Shift+v (copy and paste style) does not work on
text spans, you have to use the XML editor to ensure your kerning values
are equal from one ton another. So my proposition would be twofold:
1/Add subscript/superscript buttons (divides size by 3, vertical kerning+=
80% of original size)
2/Enable copy & paste of styles on text spans (not that easy if selection
spans several styles when copying...).

Bug Importer (bug-importer) wrote :

This is probably the only thing that is missing for me in inkscape; I need
super and subscript quite a bit.

yichun (yichun-wei) wrote :

I second this feature request.

Tom Davidson (tjd-mit) on 2008-01-09
Changed in inkscape:
importance: Undecided → Wishlist
status: New → Confirmed

Inkscape already supports subscript/superscript (and bold/italic) in accordance with SVG 1.1 chapter 10.

Changed in inkscape:
status: Confirmed → Invalid
bbyak (buliabyak) wrote :

Peter: really? since when? did you test a file with sub/sup?

Tom Davidson (tjd-mit) wrote :

I think if Bulia doesn't know about a feature in Inkscape, then it's probably not there :) See O--b's comments for discussion of how the workaround (manual vertical kerning) is not really satisfactory.

Changed in inkscape:
status: Invalid → Confirmed
Tom Davidson (tjd-mit) wrote :

Attaching a sample file from http://www.svgbasics.com/examples/text_ex7.svg . Doesn't render as superscript in SVN 17014 (Jan 10, 2008)

Bulia: Well, I did try setting characters to super-/subscript (using manual kerning) before marking the request as invalid. I'm not sure what you mean by sub/sup in a SVG context, unless you refer to arguments to baseline-shift, in which case see below.

Tom 1): yes, it's a bother to do all the steps for proper super-/subscript manually, and I agree that it would be nice to have buttons for it. In fact, it might be an idea to post a request for such buttons.

Tom 2): yes, the 'baseline-shift' property doesn't seem to matter in Inkscape's text rendering. It might be an idea to post a bug report about it.

In summary, I think that "Add buttons for super-/subscript text" and "Baseline-shift has no effect" are valid, but "Allow subscript/superscript in strings" *isn't* (nor is the description's assertion that the whole text is affected by style changes).

Tom Davidson (tjd-mit) wrote :

I see your point that the original description was invalid, but the bug has since turned into a discussion of adding super/subscript support to the UI. Best thing to do in this case is probably to rewrite the bug summary, which I'll do after this. I don't think breaking out 'baseline-shift' support into another bug is a good idea at this point, since it is really only needed to support this feature, and I think it's better to keep all the discussion in one place.

description: updated
Tom Davidson (tjd-mit) wrote :

Marking as duplicate of the 'ancient' 170324. Lots of interest in this issue...

Sum D00d (taz-the-devil) wrote :

A work around is to create the needed text in another application that supports subs/sups and copy it to Inkscape.
I do that with Open Office Draw. The XML formatting doesn't seem to be identical but it is still proper text (no path) and works well enough for labelling graphics and such.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers