Break Text, words, lines and letters.

Bug #171748 reported by Bug Importer on 2007-02-13
24
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Wishlist
Karlisson

Bug Description

Related branches

Bug Importer (bug-importer) wrote :

Much of that is already implemented, like flowtext and shifting single
letters. Some features, like tabulator support, are missing. But see:

http://tavmjong.free.fr/INKSCAPE/MANUAL/html/index.php

ValessioBrito (valessio) wrote :

Originator: NO

"Break Text" it goes much more beyond, separates words of a phrase,
allowing to all move the words for the work.

Example:
We have that to copy some lines for another work, if to exist "line In
addition" we can separately move the lines for another work. It's not for a
simple movement, that is for more complex and individual movements.
Now he imagines, if I had myself that to use the tool text for each word
that I to want an individual movement.

..>sorry my english.

Bug Importer (bug-importer) wrote :

and conversely, the joining or rejoining of letters, words and lines
(back) into one unified text group again would be stellar :)

Molumen (molumen) wrote :

Originator: NO

In Corel, if working with multiline text the "Break Apart" funtion breaks
the text into lines, then lines into words, the words into letters. The
"Combine" function does the opposite (selected letters into words, selected
words into lines, selected lines into multiline text).

I think that this is the best example to follow as it is:

a)an upgrade of an existing function ("Break Apart" and "Combine" are
already present in Inkscape, no need to create a new function for text, no
new keyword needed)

b)it is very intuitive.

:)

hash (hash-g) on 2007-12-08
Changed in inkscape:
importance: High → Medium
status: New → Confirmed
Tom Davidson (tjd-mit) on 2008-01-05
Changed in inkscape:
importance: Medium → Wishlist

I like it. Has this been implemented in Inkscape? If so, how do you break apart text?

Karlisson (karlisson) wrote :

Hi,

I've recently created a Python extension for breaking apart text:
http://nerdson.com/bin/split/split.py
http://nerdson.com/bin/split/split.inx

Hope you enjoy! ;)

Karlisson (karlisson) wrote :

Commited a Python extension for breaking text.

Changed in inkscape:
assignee: nobody → karlisson
status: Confirmed → Fix Committed
jazzynico (jazzynico) on 2009-04-20
Changed in inkscape:
milestone: none → 0.47
su_v (suv-lp) wrote :

Setting status back to 'In Progress' since the useful extension by Karlisson hasn't been committed to SVN trunk yet. Voting to include it and changing milestone to 0.47.1 as it's too late for 0.47 now.

Changed in inkscape:
milestone: 0.47 → 0.47.1
status: Fix Committed → In Progress
jazzynico (jazzynico) on 2010-04-20
Changed in inkscape:
milestone: 0.47.1 → 0.48
jazzynico (jazzynico) wrote :

Extension added in bzr revision 9360.

Changed in inkscape:
status: In Progress → Fix Committed
jazzynico (jazzynico) on 2010-08-24
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers