poppler-0.58 breaks inkscape build

Bug #1715820 reported by Thomas Klausner
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Fix Released
High
Patrick Storz

Bug Description

Building inkscape-0.92.1 with poppler-0.59 fails:

```
.../inkscape/work/inkscape-0.92.1/src/extension/internal/pdfinput/pdf-parser.cpp: In member function 'void PdfParser::parse(Object*, GBool)':
.../inkscape/work/inkscape-0.92.1/src/extension/internal/pdfinput/pdf-parser.cpp:417:29: error: invalid conversion from 'Object*' to 'int' [-fpermissive]
       obj->arrayGet(i, &obj2);
... ^
````
(2000 more lines, see attachment)

This is another occurrence of breakage due to using the non-public API, see https://bugs.launchpad.net/inkscape/+bug/239544

Revision history for this message
Thomas Klausner (tk-giga) wrote :
Revision history for this message
Patrick Storz (ede123) wrote :

I committed a fix by David to master yesterday:
https://gitlab.com/inkscape/inkscape/commit/9418824967eb4c53371ef8588243fed4cab496e0

If no issues are found I plan to back-port it to the 0.92.x branch eventually.

Changed in inkscape:
assignee: nobody → Eduard Braun (eduard-braun2)
status: New → Confirmed
importance: Undecided → High
Revision history for this message
Patrick Storz (ede123) wrote :
Changed in inkscape:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Bug attachments