Measurement tools

Bug #171494 reported by Urpo Lankinen on 2006-09-04
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Wishlist
Felipe "Juca" Sanches

Bug Description

I'd love to see user-adjustable measurement tools.
These tools are kind of inspired by the tools in GIMP
and AutoREALM (http://autorealm.sourceforge.net/).

I'm using Inkscape to create fictional maps, so good
measurement tools would be very nice.

Basically, it would be nice if Inkscape had two
measurement tools:
* (Angle) ruler: Measure distance between two points,
and tell the angle between x axis and the straight line.
* Measurement string: Operates like the freehand
drawing tool, but instead of generating a path object,
tells how long the path is. Would be useful in
determining the lengths of roads etc.

It would also be fun if the tools could be set to
measure both the physical document dimensions, and any
arbitrary scale of choice (ie, set 10 mm on document =
5 km in real or imagined world).

I probably wouldn't ask if AutoREALM could import SVG,
but still, if GIMP has measurement tool, I'd love to
see one in Inkscape too. =)

nightrow (jb-benoit) on 2007-12-16
Changed in inkscape:
importance: Undecided → Wishlist
vonHalenbach (lustik) wrote :

Thank you for your input to make Inkscape better. I have put your wish on our wishlist.

Changed in inkscape:
status: New → Confirmed
Gerhard Bräunlich (wippbox) wrote :

I'd love to see that too!
I have an additional suggestion for the "scale of choice" feature:
One could introduce special shapes (or use the existing ones) to which one can assign (x- and y)-scales. All dimensioning object placed into such a shape (i.e a box) would use the specific scale of that shape.

This way it would be possible to have multiple maps with different scales in the same document.

KarlStiler (khruskowski) wrote :

I'd would be a great feature!
And of course i have more suggestions :)
The user should be able to configure a key to copy the measured data to the clipbord.

Benoy George (bge007) wrote :

Thank you for the great application. I have just started using for some of my projects. It would have been great if measurement and relative positioning options were available...

Actually "Measure path" extension is already available since 0.45 or so :)

su_v (suv-lp) wrote :

@Felipe - could you take a look at this feature request with regard to your new measure tool?

It seems to me that the new Measurement Tool that I have been inplementing fullfills some of the requests found here.

Changed in inkscape:
assignee: nobody → Felipe "Juca" Sanches (felipe-sanches)
su_v (suv-lp) on 2014-05-15
tags: added: measuretool
removed: other
Jonathan Hofinger (jhofinger) wrote :

Closing as Fix released. There are multiple options to measure paths and angles, including the "Measure path" extension, the "Measure segments" LPE, and the ruler tool. Closing as Fix released.

Please feel free to file new bugs about the issues you're seeing at http://inkscape.org/report.

Closed by: https://gitlab.com/jhofinger

Changed in inkscape:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints