Hatching

Bug #171369 reported by Ejgrace on 2006-06-26
2
Affects Status Importance Assigned to Milestone
Inkscape
Wishlist
Unassigned

Bug Description

Filling with a hatching pattern is extremely difficult
and needs to be simplified. Ensuring that the lines of
the hatching join up is a nightmare.

This needs simplifying, hatching is a common
requirement in technical illustration.

Horkana-users (horkana-users) wrote :

A preset collection of patterns would probably make this easier
if you put in a request to OpenClipart.org they migth be
willing to creat the necessary hatching patterns

(I've created them before and could do it again but I cannot
afford to until I'm am otherwise gainfully employed.)

Xorx (xorx) wrote :

Originator: NO

I agree with the initiator of this request. Hatching should not be
supported with a library but as a an alternative to fill patterns. Also
fill patterns do not well export to postscript and other vector formats. A
true hatching seems to me the only working alternative and it is *really*
required for technical illustrations!

Also I think it would be rather simple to implement. The parameters would
be:
* hatch distance
* hatch angle

The line width, style, and colour could be inherited from the objects line
style.

I beg anybody who can do it to implement it, since it is really a simple
feature with a high usability improvement for Incskape.

Thank you

Georg

Xorx (xorx) wrote :

Originator: NO

While thinking about hatching I got a more precise idea how it should look
like:

Hatch-style would be an additional tab in the object properties containing
the follwing informations:
* line width
* line style

And three (my suggestion) individual sets of
* hatch distance (zero to switch hatch off)
* hatch angle (direction for this set)

This would allow the easy parametrization of more than 90% of common
hatches. I made a UI-mock-up wich I did not manage to load up jet...

Bug Importer (bug-importer) wrote :

Hi all !

yes that's be very nice to have real hatching capabilities !

thank's

nightrow (jb-benoit) on 2007-12-16
Changed in inkscape:
importance: Undecided → Wishlist
status: New → Confirmed
bbyak (buliabyak) wrote :

there are many predefined hatching patterns in Fill&stroke, pattern tab. They all line up, and you can use on-screen handles to scale and rotate them.

Changed in inkscape:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers