Document Prefs' Default Unit should be set for grid/guides

Bug #171277 reported by Bug Importer on 2006-05-13
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Inkscape
Low
Unassigned

Bug Description

Setting the default units on the first tabulator page
in the document preferences should also setup the units
to the same unit for both the grid and for the guides
as requested.

Ryan Lerch (ryanlerch) on 2007-12-13
Changed in inkscape:
importance: Undecided → Medium
status: New → Incomplete
Maximilian Albert (cilix) wrote :

I believe this also applies to the units used in the various toolbars; these should also use the chosen document-wide unit as default.

Tom Davidson (tjd-mit) wrote :

I would like to see this behavior, too. Now that the grid spacing is newly calculated when the units are changed, (bug 168912), perhaps this will be less painful to implement.

Changed in inkscape:
status: Incomplete → Confirmed
importance: Medium → Low
KevinM (kevbert1) wrote :

Using Inkscape 0.46. Default units can also be set in the templates. This sometimes changes the stroke units. It does not change the units for object sizes (which can be annoying). Would it be possible to use the default unit value in the templates to be a global (default) setting for all units?

Arthur Magill (arthur-magill) wrote :

Using 0.46, this bug is still here. It's not a show-stopper, but it is irritating (it breaks the normal it-just-works Inkscape zen!).

su_v (suv-lp) wrote :

Still present in Inkscape 0.46+devel 22575 and 0.47pre4 on OS X 10.5.8.

Johan Engelen (johanengelen) wrote :

You can set the default grid unit in Inkscape's preferences. This may help you a little bit.

jazzynico (jazzynico) wrote :

Since the default grid unit is already set in the preferences, which unit should be used by default? The one in the preferences, or the document unit?
We could also have a "default" entry in the preferences list to tell Inkscape to use the document unit.

su_v (suv-lp) wrote :

> We could also have a "default" entry in the preferences
> list to tell Inkscape to use the document unit.

That would be great, imho (if this can be easily implemented…).

jazzynico (jazzynico) on 2010-09-26
Changed in inkscape:
assignee: nobody → JazzyNico (jazzynico)
pRototype (regeir) wrote :

Still an issue in Inkscape 0.48+devel r10611.

It's an anoying to always readjust grids when default units is mm (or other).

jazzynico (jazzynico) on 2012-09-18
Changed in inkscape:
assignee: JazzyNico (jazzynico) → nobody
su_v (suv-lp) on 2012-09-26
tags: added: preferences units
su_v (suv-lp) on 2014-11-24
tags: added: easy-fix
Changed in inkscape:
assignee: nobody → Kuntal Majumder (hellozee)
Kuntal Majumder (hellozee) wrote :

Cannot produce with trunk.

Changed in inkscape:
status: Confirmed → Fix Released
Mc (mc...) on 2018-03-06
Changed in inkscape:
assignee: Kuntal Majumder (hellozee) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers