Please support extended tablet capabilities

Bug #171265 reported by Jediry on 2006-05-07
6
Affects Status Importance Assigned to Milestone
Inkscape
Wishlist
Jon A. Cruz

Bug Description

I love Inkscape...but it would be even better with
support for the extended input abilities of my Wacom
tablet (e.g., pressure/tilt sensitivity, separate tools
mapped to the pen and eraser ends of the stylus).
GIMP's way of doing this isn't bad, but needs to allow
better customization of button behavior.

Keep up the awesome work!

We already support pressure/tilt sensitivity of tablet in
the calligraphic tool. Please give more specific suggestions.

Jon A. Cruz (jon-joncruz) wrote :

Originator: NO

We'd love to add more support for the device ID (eraser, different styli,
etc), but need some support from users who actually own such hardware.

Jediry (jediry) wrote :

Originator: YES

OK, after a year hiatus, during which my tablet driver was hosed, I'm
back.

I just tried out the pressure/tilt sensitivity and it makes me happy. Very
nice...I'm going to have fun with this. :-)

The one thing that is still missing, IMO, is the ability to map different
tools to different ends of the stylus. For example:
  1. Click the calligraphy tool with the stylus point, doodle with it for
a while.
  2. Click the selector tool with the "eraser" end of the stylus, and use
it to select a few things.
  3. Flip the stylus back over to use the point again.

Desired behavior: once my tablet senses that I'm using the point again, it
immediately switches back to the calligraphy tool
Actual behavior: using the stylus point, I'm still in "selector" mode.

GIMP lets me do this, and I find it especially useful there, because I map
"brush" to the point and "eraser" to the eraser end of the stylus. In
Inkscape, this would be slightly less useful, since you don't have an
eraser tool (hmmm...maybe I'll file a wishlist item for that), but it would
still be nice to be able to switch back and forth between two commonly used
tools.

Also, it might be interesting to allow the two stylus ends to share the
same tool, but different color/fill/line-style options (e.g., thin black
pencil on one end, thick red pencil on the other). I suggest this idea with
some hesitation, because it seems like this could make the UI more
complicated...not sure that it's a *good* idea, but it's an idea. :-)

Hystrix (hystrix-) on 2007-12-20
Changed in inkscape:
importance: Undecided → Wishlist
status: New → Confirmed

Jon, what kind of support do you need? :) I can give most, if not all of it :)

Changed in inkscape:
assignee: nobody → jon-joncruz
status: Confirmed → In Progress
Jon A. Cruz (jon-joncruz) wrote :

Basic switching of tools has been committed to SVN. The settings and behavior need a bit of refinement, but it is at a point where people testing on different tablets and configurations would be helpful.

Frank Maker (flmaker) wrote :

I have a Wacom Bamboo Fun and would love to help test the tools switching. Where can the new features be found in SVN?

Jon A. Cruz (jon-joncruz) wrote :

In general I think much of this is covered by 0.47. Individual details still needed should get added as individual bugs.

Changed in inkscape:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions