Border in palette swatches

Bug #171177 reported by Molumen on 2006-02-25
This bug affects 1 person
Affects Status Importance Assigned to Milestone
John Smith

Bug Description


I would like to suggest to add borders to the
Inkscape's palette swatches.

I took a look at several major (and minor) graphic
softwares, and saw that all of them had borders around
color swatches in the color palettes.

In the attached file, there are screenshots of the
color palettes of the following software:
- Corel Draw 12 (2 variants with wide and default
border size, as this program the possibility to swith
between the border sizes)
- Scibus 1.3.2
- Xara Xtreme (the only program where borders were
replaced by bigger spaces between swatches: swatches
aren't square but colors doesn't mix)
- IconoMaker 1.0 (a freeware icon creator)
- Adobe Illustrator 10
- Adobe Photoshop 7
- ACD Canvas X
- Macromedia Flash MX

I made a small test to understand the need of such a
border. See the second attached file where I compare a
palette with and without bvorders. IMO the one with
borders is a lot more legible and every color is
distinctly seen.

Please post here your thoughs about wether there should
or shouldn't be borders in Inkscape's color swatches.

Thanks! :)

P.S.: A big shout to Joncruz in charge of the palette
implementation for all the feedback he gave me. ;)

In Xara, there are NO borders if you look at the square (not
diamond) swatches. And this is IMHO the only program which
gets this right. Other programs' annoying borders which
prevent me from easily comparing the adjacent colors are
pure evil.

That said, I won't object if someone implements them in
Inkscape as an option, with default off.

nightrow (jb-benoit) on 2008-01-05
Changed in inkscape:
importance: Low → Wishlist
status: New → Confirmed
dopelover (dopelover) wrote :

A big problem apears in "Auto" palette that stores also gradients. With no borders in some particular cases there is a real problem to see where one swatch ends and other begins. On attached screenshot there is an example. I've created few gradiens that has black ends and it is impossible to determine:
1) how many swatches is in palette
2) how does any of the swatches looks like

So we have to decide how to distinguish swatches otherwise in similar cases the "Auto" pallete is totally not in working order.

IMO there is no point in having borderless swatches in the palette. The colors just split together in a line and it is very difficult (and in some cases almost impossible) to locate a precise color (just look at some of inkscape's standard palettes like the blue, gold or gray). There is no point in having one single gradient line in the palette since there already is the color properties window that can be used to achieve the same result (have a color gradient line to choose a precise color from it). See the attached screenshot showing the gray palette and the color properties window.

Inkscape's swatches needs borders (at least as an option that can be switched ON or OFF), every time I use the palette I am reminded of this problem.

jazzynico (jazzynico) on 2011-03-17
tags: added: color
removed: ui-palette-color
John Smith (john-smithi) wrote :

Patch that adds a couple of border options.
Can be set separately for the Swatches and the Palette from their popup menus.

Changed in inkscape:
assignee: Jon A. Cruz (jon-joncruz) → John Smith (john-smithi)
status: Confirmed → In Progress
~suv (suv-lp) wrote :

> 171177.v1.patch
> Patch that adds a couple of border options.

Can't seem to get the solid borders to show in the 'Auto'-palette (looks the same as 'None') - 'Spaced' does work though (both in the palette of the main window, as in the 'Swatches' dialog). All three options work ok with regular (predefined) palettes.

If displayed unwrapped (default) - in a long single row in the palette of the main window - the omitted (?) border at the bottom of each color swatch is slightly irritating (giving the impression as if the palette is only partially displayed, or cut off at the bottom)

Tested with r11701+171177.v1.patch, with different gtk themes and both backends of GTK+ on OS X 10.7.4.

John Smith (john-smithi) wrote :

Thanks for the testing ~suv, v2 patch attached should fix those issues :
* Auto palette should work with all border options
* Bottom border should show in palette as well

~suv (suv-lp) wrote :

> * Auto palette should work with all border options
> * Bottom border should show in palette as well

Both confirmed - works as expected with second patch.

Is there a consensus that the new default is to render with (black) borders for both the palette in the main window and the 'Swatches…' dialog? I can't recall having read lots of complaints by regular users (with default inkscape palette) about the current display (without borders)…

John Smith (john-smithi) wrote :

Committed r11706 : Keep the default border as "none".
Will check with the list on the preferred default.

Changed in inkscape:
status: In Progress → Fix Committed
~suv (suv-lp) on 2012-09-27
Changed in inkscape:
milestone: none → 0.49
Bryce Harrington (bryce) on 2015-02-21
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers