PDF better under "Export" than "Save As"

Bug #171054 reported by Endecotp on 2005-12-22
66
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Inkscape
Wishlist
Unassigned
inkscape (Debian)
Confirmed
Unknown
inkscape (Ubuntu)
Wishlist
Unassigned

Bug Description

Currently the "Save As" dialog lists vector formats
including PDF, PS and so on, while the "Export" dialog
supports bitmap formats (PNG, etc?).

In my typical usage, which I don't imagine is unusual,
all formats other than SVG would be better considered
as "Exports". If I want to make a PDF file I currently
have to "save as" PDF and then remember to "save as"
the original SVG file again so that subsequent saves go
to the right place.

I think it would improve useability to include bitmap
and vector formats such as PDF in the "Export" dialog.
 Alternatively, an additional menu entry "Export
vector..." could be included next to "Export bitmap...".

Another approach is to have a "save a copy" dialog
where a different file type can be chosen without
affecting the filename and format that will be used for
subsequent normal saves.

--Phil.

Molumen (molumen) wrote :

Phil,

I agree with you on that, your idea increases document and
workflow management.

Please take a look at https://sourceforge.net/tracker/index.
php?func=detail&aid=1377887&group_id=93438&atid=604309

It's in "features request" and raises the same problem about
"save" and "export" functions.

Thanks

Horkana-users (horkana-users) wrote :

s/useability/usability/

The split between Save/export is a fairly important design
point which needs to be done in a through and consisten
manner. it would need to be justified, carefully planned
out, and discussed in depth on list.

vonHalenbach (lustik) wrote :

This feature request is quite old. We have already a mechanism implemented, which prevents the user to loose vector data, through accidentially saving into a bitmap format, with a nagscreen, to remind him to save into svg also. In my humble opinion this can be closed.

Changed in inkscape:
status: New → Invalid

vonHalenbach: I don't see how the fact that the current mechanism prevents the loss of vector data is linked to this bug.

The bug (or RFE maybe) is that the typical workflow when productng pdfs is to have the svg be the document and the pdf the export target. For instance, batch export is really nice, but why restrict it to ugly pngs? Moreover, the current solution with "save a copy" is really sub-optimal: the name of the export is never remembered between sessions, and exporting only a part of the drawing is clumsy. And consistency is also really bad: everyone thinks of saving as pdf as an export, not a save. Witness the fact that if your save your work as pdf and close, inkscape nags you.

ScislaC (scislac) wrote :

Florent,

What do you mean by "ugly pngs"? They are lossless and with the highest quality rendering that Inkscape does.

Additionally, I don't think of saving as pdf as an export function... so, not everyone. Given that I've used Illustrator for over a decade, it's been a function of Save. In fact, in the version we have at my office, you can't even find pdf in the Export dialog, it's only in the Save dialogs.

Since you brought up the "nag" dialog after saving as pdf and attempting to close, what vonHalenbach said ended up being directly related to this bug report (you complained about the feature he was explaining). Regarding your complaint about the nag, currently there are some things which must be rasterized because PDF does not support them... the "nag" screen just reminds you to save an SVG copy to ensure full editability in the future.

Krzysztof Kosinski (tweenk) wrote :

In my understanding:
Save = you can open the file again in Inkscape and expect most of things to be still editable
Export = you don't know whether you will be able to change something afterwards

My opinion: Allow to export to ALL formats (bitmap and vector alike) and put only formats which preserve most of the vector information in the Save dialog.

While this might seem like an UI duplication, it's not - exporting is definitely different from saving. Additionally, batch export to vector files (like PDF) can be useful too - consider i.e. artwork for a book in LaTeX which you would like to keep all in one file, and then export to separate PDF images for processing. Having too much options to choose from can be solved too - just allow to turn off some of the formats in the preferences menu.

I agree totally with Tweenk. The latex example is exactly my situation.

Doing the interface change Tweenk suggests would have many benefical effects:
- Solve this bug
- Solve #168627
- Solve #170458 (isn't this bug a duplicate of #170458 ?)
- Allow a workaround for #171607
- Remember where to save when saving as pdf. (Work on a svg, save a copy as pdf, then save the file as svg, then when you want to save a copy again, the name by default is not the name of the pdf).
- Make working with pdf easier by not having to change the file type manually everytime you save (same use case as previous item)
- Allow Batch and partial exports into pdf and other vector formats. (This would be really really great).
- Maybe I'm forgetting some

All that for the price of a small choice box in the export dialog.

Does the code needed to use the other exporters than png on a selection exist ? Would it be hard to add ? I guess not, in the worst case, just copy the selection into a temporary svg and use the exporter on that.

To answer scislacs' question:
-What I mean by ugly pngs is not that they have a rendering problem. Rather, I mean that when I want to produce a pdf for example with latex, going through pngs for parts of the document is not satisfactory. Especially if I my drawing wouldn't run into things that need to be rasterized if they were put into a pdf. Btw, my point about the nag dialog was that it was a symptom of the problem, not its resolution.

JiHO (jiho) wrote :

I also wholeheartedly agree. Th only formats that should be in Save is are "Inkscape SVG" and "Inkscape SVGZ", in all the others at least some of the editing functionality is lost (even with plain SVG things such as rotation centers and probably also 3D objects now, are lost). So they should all go under Export and the nag screen should be suppressed.

So the request is two fold:

- move most of the current save as formats to export. This can be done quickly provided that we reach some agreement on the devel list. This was discussed before but never settled. I guess we should restart this discussion after the release of 0.46 and the best way to settle the debate would be for someone to provide a patch with the proposed new behaviour, so that it can be evaluated in real life

- provide the same functionality in vector export than in bitmap export. namely: batch export and export only part of the drawing. These are more long term goals and may not be as easy. cropping the vector info is a possibility but ideally it should crop only the necessary objects and completely discard the rest, which is more challenging. But these difficulties should not prevent the first change to be made as soon as possible.

For reference these are the behaviors of some graphic apps regarding save/export (please complete the list if you have access to others, Xara in particular):
Save only in native format(s) and export for everything else:
- Dia
- Xfig
- OpenOffice Draw
- Omnigraffle (OS X)
- LineForm (OS X)

Save as allow lossy formats (with a nag screen)
- Skencil. There is no nag screen proper, but trying to save as PDF from the Save menu is interpreted as an export command: the PDF file is saved but the current working file is kept as sk. Strange design decision and not one to follow IMHO.
- Karbon14: save and export present the same formats: only karbon14 native and odg on my machine (which seems odd). Don't know if odg is lossy but I guess so.

Special cases:
- Adobe Illustrator. This is a particular case: Illustrator allows to save as different formats but which are Adobe PDF, Adobe EPS etc. These files contain in fact two streams of data: regular EPS/PDF/SVG info on one side and the AI equivalent on the other (this corresponds to the "Preserve Illustrator editing capability" in the save menu). These are, from common agreement, very bad formats. When the option "Preserve ..." is unchecked, there's not even a nag screen...

Changed in inkscape:
importance: Low → Wishlist
status: Invalid → Confirmed
jazzynico (jazzynico) on 2009-11-09
tags: added: exporting
Changed in inkscape (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
Changed in inkscape:
status: Confirmed → Triaged
Changed in inkscape (Debian):
status: Unknown → Confirmed
David Mathog (mathog) wrote :

The initial report here concerned the implicit action of "Save as" which is:

  and make all subsequent "Save" operations also write to this file

and then discussion spun off into "Export" and a wholesale rearrangement of "Save" and "Save as...". Current versions of Inkscape have "Save a copy..." in the file menu , which is nothing but "Save as.." without this implicit action.

So why is this bug still open? End users can already achieve the desired result by selecting that other file menu option.

If this is still considered an issue, would not a bit of text in the "Save as.." dialog, warning the user, not suffice? Perhaps
place it below "Title" and have it say:

  This file will also be the new target for "Save". To retain the current "Save" target cancel this dialog
  and use "Save a Copy" instead.

Alternatively, put in a check box, normally checked, that says:

  Make this the new target for "Save"

If it was deselected, then "Save as..." would act like "Save a copy" does now.

The latter change pretty much eliminates the need for a "Save a copy" file menu option, at the expense of an occasional extra mouse click within the "Save as..." dialog.

Not having vector formats (including svg) under export is still an annoyance:
- Users needing to learn to use the least intuitive option is still a bug
- Using save a copy sets the default directory/file extension (you have to explicitely reselect pdf each time, which is *very* error-prone (hello drawing.pdf.svg)
- You can't export a part of a drawing as pdf (or svg/eps for that matter)
- You can't use batch export into pdf
- The solution you propose would eliminate the need for Save a copy "at the expense of an occasional extra mouse click" whereas allowing vector export (ie, merging export and save a copy) would eliminate the need for Save a copy at the expense of *nothing at all*.

Hi folks. I agree with Phil, Molumen and Horkana-Users:

It would be more efficient and organized in the Inkscape app if we had "Save" and "Export" options. It would be more organized and easier to understand.

I believe that the Save options should have mainly Inkscape SVG and some of the other SVG options.
In the export options we should have mainly other vector formats and raster formats. Gimp 2.8.x has this option and I think it`s definitely a plus.

Ryo Furue (furue) wrote :

I agree that "Save" and "Save As" should be restricted to Inkscape-compatible SVG and all other formats should be handled by "Export".

Reading through the past postings, I notice there is confusion between these two notions:

1. The current implementation (mine is 0.91) is functionally complete
     in the save/export department.

2. The current implementation isn't optimal.

You can certainly "export" to PDF by "saving as" (item 1). But the current implementation is a bit confusing and annoying (item 2).

You edit your SVG image and save it; you then "save" it as PDF; you try to quit inkscape, but it insists that you have to save it as SVG not to lose your edits.

Why does this happen? Because the notions of "saving" and "exporting" aren't clearly distinguished.

By convention (look at major wordprocessors, image editors, etc.), "save" means save the current document. Therefore, "saving as" PDF means that you save the current document as PDF and then the new PDF file "becomes" the new current document. Subsequent saving overwrites to that PDF file. Then why ask about SVG when quitting inkscape?

The fact is that the current document cannot "become" PDF because PDF cannot express everything the inkscape-SVG does: when you export to PDF, some information is lost. Therefore you cannot "save" as PDF: all you can do is to "export" to it.

. . . This is how the two notions are distinguished by convention. It's desirable that Inkscape should follow the convention, not to confuse or irritate the user.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.