0.92.2: 32 & 64 bit versions fail to launch on Win10

Bug #1710434 reported by Bob G on 2017-08-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Unassigned

Bug Description

Uninstall/install proceeds without errors in .exe and .msi versions. Upon launch, inkscape.exe persists in Task Manager for about 10 seconds, then disappears with no error output. Program never launches. 0.91 worked fine on this system, but 0.92 will not launch.

Bob G (tecer2003) on 2017-08-13
description: updated
tags: added: crash win32 win64
Hachmann (marenhachmann) wrote :

Bob, can you run Inkscape from the command line and copy-paste any messages that you get?

Eduard Braun (eduard-braun2) wrote :

@Bob: Just for completeness - you have to execute the command "inkscape" (withot file extension) or "inkscape.com" on the command line as "inkscape.exe" won't output anything on the command line due to limitations of the Windows OS.

@Maren: Thanks for chiming in! I'll likely be offline the next few days so any help is more than welcome!

Hachmann (marenhachmann) wrote :

offtopic: @Eduard: Hope that's going to be a pleasant break! It would be well-deserved.

Bob G (tecer2003) wrote :

I tried the command line as you described. No error output was shown; the prompt just returned when the program exited. I ran "SimpleProgramDebugger" from Nirsoft during the launch; it just showed the load/unload of dll's and release of threads with addresses. I am 99% sure it would not be meaningful debug information. If I knew your versions of build environment and debugger I could launch them after installing. It seems others have had similar issues like this. Since I'm not a developer the finer points of that are lost on me.

FWIW, I attempted a download of VisualStudio (now "Community Edition") with a very modest selection of languages and platforms, one kind of .Net (would have preferred none), etc. The proposed binary download: 13 GB (thirteen). I declined. You have a memory leak of a GB here and a GB there, pretty soon you are talking about some real memory loss.

The SR-71 Blackbird mach 3+ plane was designed with how many kB? None!? Oh... :( (Actually in 1962 there probably was a kB or two behind their nixie tube displays). Now that nixie tubes are back in production, could it be time for Inkscape to port to, horrors, QT? ...and Python 4? jk (or am I?)

Hachmann (marenhachmann) wrote :

Bob, unfortunately I cannot help with debugging on Windows, we may need to wait until an Inkscape-on-Windows developer comes back.

Perhaps these instructions will be useful, though:
https://inkscape.org/en/develop/debugging/

Eduard Braun (eduard-braun2) wrote :

Hi Bob, we built Inkscape 0.92.2 with MSYS2. If you're familiar with gdb (GNU Debugger) you can find a compatible version at [1] (for 64-bit). Extract the archive with intact directory structure into your Inkscape directory, then move the executables from the /bin folder into the root directory.

Unfortunately I'm not sure if this will be enough (from your explanation it seems Inkscape does not actually crash but exits without ever showing the GUI) but it's certainly worth a try.

Two additional questions:
- Did you install Inkscape into a "clean" directory
  (i.e. was it empty before installation?)
- can you attach the output of the command "set"
  when executed on a console (cmd.exe) so we can check if
  there are any environment variables that could cause issues)

To rule out path issues another thing you can try:
- launch a console (cmd.exe) and navigate to the Inkscape directory
- execute "set PATH=C:\WINDOWS\system32;C:\WINDOWS" (without quotes)
- execute "inkscape.com" and see if it solves the issue

[1] http://repo.msys2.org/mingw/x86_64/mingw-w64-x86_64-gdb-8.0-2-any.pkg.tar.xz

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers