Scrapbook-like symbol library

Bug #170567 reported by Frederik Elwert
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Fix Released
Wishlist
Tavmjong Bah

Bug Description

Would it be possible to implement a symbol library in
Inkscape? SVG has the symbol-element, so why not use
it?

Greetz
Freedo

Tags: objects ui
Revision history for this message
Buliabyak-users (buliabyak-users) wrote :
Revision history for this message
Frederik Elwert (frederik-elwert) wrote :

I think Bug #170059 itself is not really well defined, so it is difficult to determine if this is really a duplicate.

From my understanding: Bug #170059 requests “something like Dias shape libraries”, so a default library of shapes that Inkscape ships. This library would be available from all documents, similar to the current OpenClipArt integration (but probably offline).

In contrast, this report requests the possibility to define symbols from a document and reuse these symbols in the document. This is more similar to Scribus’ “send to scrapbook” feature: One can select an arbitrary object in a document and save it as a reusable item. Via the scrapbook window, one can access these objects.

The current workflow often includes having default shapes in the document in the margin area and create clones from them. With a symbol library implemented, one could keep these objects off the canvas and have them in a separate window. Technically, SVG provides the “symbol” element to define such off-canvas objects for later re-use in a document. But this feature request is independent of the technical implementation details.

So I vote that this is *not* a duplicate of Bug #170059, both describe independent feature requests.

Revision history for this message
su_v (suv-lp) wrote :

> In contrast, this report requests the possibility
> to define symbols from a document and reuse these
> symbols in the document.

Reverting duplicate status for now as requested - not sure about it though, because implementing this feature would certainly use the same or similar infrastructure as handling external shape libraries, both on the technical level (<symbol|use> as well as with regard to UI widgets - difference being if the library is scrapbook|external and editable|preset.

Changed in inkscape:
importance: Undecided → Wishlist
status: Invalid → New
su_v (suv-lp)
summary: - Symbol library
+ Scrapbook-like symbol library
jazzynico (jazzynico)
Changed in inkscape:
status: New → Confirmed
tags: added: objects ui
Revision history for this message
su_v (suv-lp) wrote :

On 2010-07-05 14:11 (+0200), Frederik Elwert wrote:
> (...) this report requests the possibility to define symbols from a
> document and reuse these symbols in the document.

and

> The current workflow often includes having default shapes in the
> document in the margin area and create clones from them. With a symbol
> library implemented, one could keep these objects off the canvas and
> have them in a separate window.

Implemented with the new 'Symbols' dialog in Inkscape 0.91

(Offers access to symbol libraries, as well as to all symbols defined in the current document, and allows to insert clones of individual symbols from the dialog via drag&drop onto the canvas).

Closing as 'Fix released' with milestone 0.91.

Changed in inkscape:
assignee: nobody → Tavmjong Bah (tavmjong-free)
milestone: none → 0.91
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.