sets (named selections)

Bug #170286 reported by Buliabyak-users on 2004-06-12
26
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Wishlist
Liam P. White
Experimental
Wishlist
Liam P. White

Bug Description

* an object can be in zero or more sets

* this is determined by the inkscape:sets attribute,
which holds a
whitespace-separated list of layer IDs (NMTOKENS); sets
fundamentally exist just by virtue of being referenced

* UI: a single combo box on the selector top panel
where you can type in the new name of your current
selection, or select one of the defined names from a
drop-down to reselect them

* when you happen to manually select exactly the
objects that make up one of the sets, that set's name
is displayed in the combo box - the same end result as
if you selected the name from the list and thus caused
it to be selected

* when one of the names is shown in that combo box, you
can erase it, which results in removing this set from
the list of defined sets (objects remain, they're just
not in the set anymore); maybe a small button near the
box can also be added for this purpose

* when you select something and then type the name of a
set in the combo box (rather than select that name from
the list), the current selection is added to that set,
rather than replace it

* in the Object Properties dialog, add a Sets drop-down
list next to Id, which would list (and allow you to
edit) all sets that the currently selected object
belongs to

** make the entries in the list all directly editable,
and include a blank entry at the bottom for typing in a
new one

** to delete an entry, just hit delete when it's
selected, or edit the entry and backspace over the
whole thing

** for multiple selections, list only those sets to
which all selected objects belong

* in the same dialog, enable the visible/active
checkboxes to be applicable to any number of selected
objects - that will let you select one of the sets and
hide/unhide it with a couple of clicks

Related branches

Horkana-users (horkana-users) wrote :

if these sets are your "Not Layers" idea could you add
something like not Layers to the summary and see about
closing these requests for Layers
http://sourceforge.net/tracker/index.php?func=detail&aid=857357&group_id=93438&atid=604309

Is this still to be considered a feature request?

Changed in inkscape:
importance: Undecided → Wishlist
status: New → Incomplete
ScislaC (scislac) wrote :

Closing due to being out of date and lack of follow-up, but, please reopen with the requested response if you would like us to look into it further.

Changed in inkscape:
status: Incomplete → Invalid
su_v (suv-lp) on 2010-05-04
tags: added: ui-selection-group-layer
su_v (suv-lp) wrote :

Reopening and setting to 'Confirmed' due to more recent duplicate.

tags: added: selection ui
removed: ui-selection-group-layer
Changed in inkscape:
status: Invalid → Confirmed
EmanueleSabetta (fmuaddib) wrote :

This proposal is also related to this:

https://bugs.launchpad.net/inkscape/+bug/1346420

su_v (suv-lp) wrote :

Tracking status for Experimental: 'Fix committed' in r13545
(merge of Liam P. White's branch <lp:~inkscapebrony/inkscape/inkscape>)

su_v (suv-lp) wrote :

The experimental branch was merged into trunk in r13641.

Changed in inkscape:
milestone: none → 0.92
status: In Progress → Fix Committed
no longer affects: inkscape/0.91.x
Changed in inkscape:
assignee: nobody → Liam P. White (inkscapebrony)
Bryce Harrington (bryce) on 2017-01-10
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions