"Lock guides" option

Bug #170144 reported by Acli-users on 2004-02-13
52
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Inkscape
Wishlist
Jabiertxof

Bug Description

It is rather easy to accidentally move a guide.
However, it is not possible to undo such moves.

If the user has lots of carefully-placed guides (not an
inconceivable thing, my drawings almost always have
dozens of guides), it is devastating to accidentally
move even one guide, unless the user remembers to save
very frequently.

It would thus be very nice to have a "lock guides"
command, so that once placed, guides cannot be moved
unless the user disables the "lock guides" option.

Guide move undoability is a bug, it will be fixed.

Guide lock would be useful indeed. But for now, you can just
hide guides temporarily by the | key.

Ryan Lerch (ryanlerch) wrote :

Guide moves can now be undone.

Changed in inkscape:
importance: Undecided → Wishlist
status: New → Confirmed

@Buliabyak-users - Thank you kindly for that unseen feature. Any progress on getting guides up to speed? This is from 2004 and bug #170813 ("treat guides more like objects + lock guides + some toughts") has been around since 2005.

Changed in inkscape:
assignee: nobody → John Glassmyer (john-glassmyer)
mray (mrayyyy) wrote :

It would be really nice if the guides would live inside the layers and were locked/made visible together with the layer content.
This way you could easily have locked and unlocked layers at the same time + have guides that are available just for objects that need them.

Would really be awesome to see some activity on that old issue - Thanks in advance for anybody getting your hands dirty!

Junaid P V (mjunaidpv) wrote :

It is a nice to have feature. Please implement this.

BMWDriver (quebecman) wrote :

Do want! Would make life so much easier. Thanks!

su_v (suv-lp) wrote :

Fix committed to trunk in rev 14512.

Changed in inkscape:
assignee: John Glassmyer (john-glassmyer) → Jabiertxof (jabiertxof)
milestone: none → 0.92
status: Confirmed → Fix Committed
Bryce Harrington (bryce) on 2017-01-10
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions