PALETTE: Object Library, aka shapes, stencils, etc

Bug #170059 reported by Kidproto on 2003-12-19
124
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Inkscape
Wishlist
Tavmjong Bah

Bug Description

I'm think of something like Dias shape libraries.

Maybe something like GIMPs guash: show small preview
images of the svg files so that it is easy to import
the right one.

KIDPROTO: Object libraries would simplify many
repetitive shapes needed by architects, designers, and
so forth. It would be great to implement a technology
which would take advantage of already devised libraries.

( NOTE: originally in sodipodi bug tracker as bug #
696264
, Date Submitted: 2003-03-02 15:31, comments in
sodi tracker )

4 dupes of this were just closed

Hi!

I'm not sure if I get this right, but I think that my post (https://
sourceforge.net/tracker/?
func=detail&atid=604309&aid=1113276&group_id=93438)
points in an other direction: I thought of a symbol library which
would be attached to one specific document. The user should
be able to turn any object into a symbol, using the symbol
element in the defs section. A seperate library window should
provide the possibility to insert any object as an use element.

Jonathan seems to have a general library in mind that would
be integrated in Inkscape itself.

Jon A. Cruz (jon-joncruz) wrote :

Just closed [ 1262745 ] "Object palette" as a duplicate of this

John Cliff (johncliff) on 2007-12-07
Changed in inkscape:
importance: Medium → Wishlist
status: New → Confirmed
peepo (j-chetwynd) wrote :

222971 <svg:use> closed as a dupe of this
https://bugs.launchpad.net/inkscape/+bug/222971

peepo (j-chetwynd) wrote :

#170059 is blocking #170488

please read the comments and check the links in #170488 & #222971

 'children' need the opportunity to create and share their own <use> libraries
this all becomes essential once one <externalSVGfile:use> is implemented, at least in third world, indefinitely.

http://www.openicon.org is in pre-alpha

jazzynico (jazzynico) on 2010-06-11
tags: added: objects ui
removed: other
mairin (mairin) wrote :

It would be really cool to support Calligra Flow's stencil library format. Then stencils could be shared between the two applications. Calligra Flow's format is ODG-based. For more:

http://community.kde.org/Calligra/Build_Stencils_for_Flow

Alex Valavanis (valavanisalex) wrote :

Can this be closed in 0.91? The new Symbols dialog adds this kind of functionality: http://wiki.inkscape.org/wiki/index.php/SymbolsDialog

Changed in inkscape:
status: Confirmed → Triaged
su_v (suv-lp) on 2015-03-07
Changed in inkscape:
assignee: nobody → Tavmjong Bah (tavmjong-free)
milestone: none → 0.91
status: Triaged → Fix Released
tags: added: symbols
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers